Bug 126268 - /usr/bin/perl /etc/log.d/scripts/services/http runs forever at 100% cpu load
/usr/bin/perl /etc/log.d/scripts/services/http runs forever at 100% cpu load
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-18 04:47 EDT by Mikael Collin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 08:22:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikael Collin 2004-06-18 04:47:03 EDT
Description of problem:
I'm having a problem with the logwatch scripts that runs every night. 
The problem is with the "/etc/log.d/scripts/services/http" that 
starts and then runs (at 100% CPU) until I kill the process.

Version-Release number of selected component (if applicable):
logwatch-5.1-3

How reproducible:
Every day

Steps to Reproduce:
1. Just wait for the log to run
2.
3.
  
Actual results:
The process runs forever...

Expected results:
It should stop running after a while...

Additional info:
This is what ps aux tells me:

root      2162  0.0  0.1  2204  652 ?        S    04:02   0:00 CROND
root      2163  0.0  0.1  2780  968 ?        S    04:02   
0:00 /bin/bash /usr/bin/run-parts /etc/cron.daily
root      2164  0.0  0.5  5404 2840 ?        S    04:02   
0:00 /usr/bin/perl -w /etc/cron.daily/00-logwatch
root      2165  0.0  0.1  2800  584 ?        S    04:02   0:00 awk -v 
progname=/etc/cron.daily/00-logwatch progname {?????
root      2281  0.0  0.1  2188  628 ?        S    04:02   
0:00 /bin/mail -s LogWatch for ******* root
root      2288  0.0  0.1  5696  988 ?        S    04:02   0:00 sh -c 
( /bin/cat /tmp/logwatch.gNwu2169/http  |  /etc/log.d/s
root      2289  0.0  0.1  5696 1004 ?        S    04:02   0:00 sh -c 
( /bin/cat /tmp/logwatch.gNwu2169/http  |  /etc/log.d/s
root      2290  0.0  0.0  4748  416 ?        S    04:02   
0:00 /bin/cat /tmp/logwatch.gNwu2169/http
root      2291 99.2  0.3  6464 1820 ?        R    04:02 
374:39 /usr/bin/perl /etc/log.d/scripts/services/http


The system has been upgraded from RedHat 9 to Fedora Core 1 to Fedora 
Core 2. I didn't have this problem in Fedora Core 1.
Comment 1 Elliot Lee 2004-07-14 15:33:10 EDT
Once logwatch-5.2.2 gets into rawhide, would you try that please to
see if it helps?
Comment 2 Ivana Varekova 2006-01-09 08:22:09 EST
I can't reproduce this bug on the last logwatch-7.1. There is no response from
reporter so I'm closing this bug. If there is any problem, plase reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.