Bug 1262764 - Sub-menu not present when Configuration permissions are chosen [NEEDINFO]
Sub-menu not present when Configuration permissions are chosen
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.3.0
Unspecified Unspecified
low Severity low
: GA
: cfme-future
Assigned To: Eric Hayes
Pete Savage
rbac
: ZStream
Depends On:
Blocks: 1360310 1360312
  Show dependency treegraph
 
Reported: 2015-09-14 05:49 EDT by Pete Savage
Modified: 2016-12-13 17:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1360310 1360312 (view as bug list)
Environment:
Last Closed: 2016-12-13 17:08:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ehayes: needinfo? (psavage)


Attachments (Terms of Use)

  None (edit)
Description Pete Savage 2015-09-14 05:49:38 EDT
Description of problem: When the Configure -> Configuration permissions are selected for a role, the Configuration submenu is not present at the top, even though it is accessible.


Version-Release number of selected component (if applicable): 5.3.5.4.20150709145631_c2306e1


How reproducible: 100%


Steps to Reproduce:
1. Create a role with Configure -> Configuration and Services -> Catalogs Explorer
2. Log in as new user
3. Configure page shows, but Configuration submenu is missing.

Actual results: Menu is missing


Expected results: Menu should be there


Additional info:
Comment 3 Harpreet Kataria 2016-07-25 15:28:29 EDT
Eric,

Can you try to add a new user with access to the specified features above and see if you can recreate this, if user has access to all features under Configuration, they should be able to see toolbar buttons. Let me know if you need additional info or need help with this one.

Thanks,
~Harpreet
Comment 6 Eric Hayes 2016-12-12 19:55:30 EST
I don't believe this exists in recent versions, can you confirm? (and update the menu names in the steps if necessary?)
Comment 7 Eric Hayes 2016-12-13 17:08:28 EST
Closing since it seems to be isolated to an unsupported version (5.3). Please reopen if still an issue in current versions.

Note You need to log in before you can comment on or make changes to this bug.