Bug 126290 - Grub fails to see past 8 drives
Grub fails to see past 8 drives
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: grub (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-18 11:22 EDT by Thomas Zine
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:23:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Zine 2004-06-18 11:22:27 EDT
Description of problem:
Grub fails to see past 8 devices

Version-Release number of selected component (if applicable):
grub-0.93-4 (all versions)

How reproducible:
always

Steps to Reproduce:
1. install as3 on dell poweredge 2650
2. install dell power vault 220s fully loaded with 14 drives
3. grub will fail and not re-install
device.map will not accept (hd0) /dev/sdo
grub-intall --recheck fails due to number of drives.

  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2004-06-18 17:50:46 EDT
How does it fail?
Comment 2 Thomas Zine 2004-07-01 09:36:22 EDT
grub will not be able to address any drives beyond 8 devices. If you
are hooking up an external array, grub will not locate the drive it is
installed on, due to drives being reordered. Starting the device.map
at the drive in which it is installed on (hd0) /dev/sdo also fails.
Claims invalid device.
Comment 3 Thomas Zine 2004-08-13 11:39:08 EDT
The latest ROM update from DELL for the PERC controllers modify the
load order on the PowerEdge 2650's. This appears to resolve the issue
for now. To duplicate you may have to back rev the PERC controller to
an older ROM. GRUB however, will still locate only 8 drives.
Comment 4 Peter Jones 2005-01-14 16:59:00 EST
What screen is showing you the 8 drives?
Comment 5 Thomas Zine 2005-01-19 16:09:27 EST
The source code. 
/dev/sdi through /dev/sdp in this case, grub cant recognize.
Comment 6 Peter Jones 2005-03-30 15:10:15 EST
Please show me the output of "grub-intall --recheck" when it fails.
Comment 7 David Tonhofer 2005-03-31 11:40:03 EST
I don't have the problem described here but I just came across this
remark in the Fujitsu-Siemens manual:

Linux drivers for PRIMERY servers, Revision 1.9, 23rd Aug 2004

pp 33 ff:

6.4.3. Booting fails on systems with GRUB and more than 9 hard disks.

Problem: The installation of the GRUB bootloader fails
Solution: GRUB supports only 9 (!) (sic) hard disk drives. Make sure no
more drives are specified in the GRUB device map. (...) Delete any lines
other than (hd0)-(hd8). Then re-run grub (...)

Comment 8 RHEL Product and Program Management 2007-10-19 15:23:59 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.