Bug 1262907 - [abrt] NetworkManager: nm_device_activate_stage3_ip4_start(): NetworkManager killed by SIGABRT
[abrt] NetworkManager: nm_device_activate_stage3_ip4_start(): NetworkManager ...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:10f2f4b552735407738993f4b92...
:
: 1264432 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 11:14 EDT by Mikhail
Modified: 2016-01-09 05:11 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-05 04:32:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (25.36 KB, text/plain)
2015-09-14 11:14 EDT, Mikhail
no flags Details
File: cgroup (208 bytes, text/plain)
2015-09-14 11:14 EDT, Mikhail
no flags Details
File: core_backtrace (7.25 KB, text/plain)
2015-09-14 11:14 EDT, Mikhail
no flags Details
File: dso_list (5.82 KB, text/plain)
2015-09-14 11:14 EDT, Mikhail
no flags Details
File: environ (187 bytes, text/plain)
2015-09-14 11:14 EDT, Mikhail
no flags Details
File: limits (1.29 KB, text/plain)
2015-09-14 11:14 EDT, Mikhail
no flags Details
File: maps (28.20 KB, text/plain)
2015-09-14 11:14 EDT, Mikhail
no flags Details
File: mountinfo (3.77 KB, text/plain)
2015-09-14 11:14 EDT, Mikhail
no flags Details
File: namespaces (85 bytes, text/plain)
2015-09-14 11:14 EDT, Mikhail
no flags Details
File: open_fds (2.60 KB, text/plain)
2015-09-14 11:14 EDT, Mikhail
no flags Details
File: proc_pid_status (976 bytes, text/plain)
2015-09-14 11:14 EDT, Mikhail
no flags Details
File: var_log_messages (13.25 KB, text/plain)
2015-09-14 11:14 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2015-09-14 11:14:33 EDT
Version-Release number of selected component:
NetworkManager-1.0.6-4.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/sbin/NetworkManager --no-daemon
crash_function: nm_device_activate_stage3_ip4_start
executable:     /usr/sbin/NetworkManager
global_pid:     953
kernel:         4.2.0-300.fc23.x86_64+debug
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (2 frames)
 #4 nm_device_activate_stage3_ip4_start at devices/nm-device.c:5198
 #5 nm_device_activate_stage3_ip_config_start at devices/nm-device.c:5350

Potential duplicate: bug 1176319
Comment 1 Mikhail 2015-09-14 11:14:37 EDT
Created attachment 1073309 [details]
File: backtrace
Comment 2 Mikhail 2015-09-14 11:14:38 EDT
Created attachment 1073310 [details]
File: cgroup
Comment 3 Mikhail 2015-09-14 11:14:40 EDT
Created attachment 1073311 [details]
File: core_backtrace
Comment 4 Mikhail 2015-09-14 11:14:41 EDT
Created attachment 1073312 [details]
File: dso_list
Comment 5 Mikhail 2015-09-14 11:14:42 EDT
Created attachment 1073313 [details]
File: environ
Comment 6 Mikhail 2015-09-14 11:14:44 EDT
Created attachment 1073314 [details]
File: limits
Comment 7 Mikhail 2015-09-14 11:14:46 EDT
Created attachment 1073315 [details]
File: maps
Comment 8 Mikhail 2015-09-14 11:14:47 EDT
Created attachment 1073316 [details]
File: mountinfo
Comment 9 Mikhail 2015-09-14 11:14:48 EDT
Created attachment 1073317 [details]
File: namespaces
Comment 10 Mikhail 2015-09-14 11:14:49 EDT
Created attachment 1073318 [details]
File: open_fds
Comment 11 Mikhail 2015-09-14 11:14:51 EDT
Created attachment 1073319 [details]
File: proc_pid_status
Comment 12 Mikhail 2015-09-14 11:14:52 EDT
Created attachment 1073320 [details]
File: var_log_messages
Comment 13 Jirka Klimes 2015-09-15 04:34:40 EDT
Any change you can reproduce this crash?

Would you paste the output of
$ cat /etc/sysconfig/network-scripts/ifcfg-Profile_1
and
$ nmcli con show 9d03503d-7ec9-452d-ba8d-774c542bdf8b
Comment 14 Mikhail 2015-09-15 04:48:02 EDT
> Any change you can reproduce this crash?
No idea. I even not immediately noticed that gnome-abrt have this crash.

$ cat /etc/sysconfig/network-scripts/ifcfg-Profile_1
TYPE=Ethernet
BOOTPROTO=none
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
NAME="Profile 1"
UUID=9d03503d-7ec9-452d-ba8d-774c542bdf8b
ONBOOT=yes
IPADDR=10.10.0.200
PREFIX=24
IPADDR1=192.168.1.4
PREFIX1=24
GATEWAY=192.168.1.1
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes

$ nmcli con show 9d03503d-7ec9-452d-ba8d-774c542bdf8b
connection.id:                          Profile 1
connection.uuid:                        9d03503d-7ec9-452d-ba8d-774c542bdf8b
connection.interface-name:              --
connection.type:                        802-3-ethernet
connection.autoconnect:                 yes
connection.autoconnect-priority:        0
connection.timestamp:                   1441926921
connection.read-only:                   no
connection.permissions:                 
connection.zone:                        --
connection.master:                      --
connection.slave-type:                  --
connection.autoconnect-slaves:          -1 (default)
connection.secondaries:                 
connection.gateway-ping-timeout:        0
connection.metered:                     unknown
802-3-ethernet.port:                    --
802-3-ethernet.speed:                   0
802-3-ethernet.duplex:                  --
802-3-ethernet.auto-negotiate:          yes
802-3-ethernet.mac-address:             --
802-3-ethernet.cloned-mac-address:      --
802-3-ethernet.mac-address-blacklist:   
802-3-ethernet.mtu:                     auto
802-3-ethernet.s390-subchannels:        
802-3-ethernet.s390-nettype:            --
802-3-ethernet.s390-options:            
802-3-ethernet.wake-on-lan:             default
802-3-ethernet.wake-on-lan-password:    --
ipv4.method:                            manual
ipv4.dns:                               
ipv4.dns-search:                        
ipv4.addresses:                         10.10.0.200/24, 192.168.1.4/24
ipv4.gateway:                           192.168.1.1
ipv4.routes:                            
ipv4.route-metric:                      -1
ipv4.ignore-auto-routes:                no
ipv4.ignore-auto-dns:                   no
ipv4.dhcp-client-id:                    --
ipv4.dhcp-send-hostname:                yes
ipv4.dhcp-hostname:                     --
ipv4.never-default:                     no
ipv4.may-fail:                          yes
ipv6.method:                            auto
ipv6.dns:                               
ipv6.dns-search:                        
ipv6.addresses:                         
ipv6.gateway:                           --
ipv6.routes:                            
ipv6.route-metric:                      -1
ipv6.ignore-auto-routes:                no
ipv6.ignore-auto-dns:                   no
ipv6.never-default:                     no
ipv6.may-fail:                          yes
ipv6.ip6-privacy:                       -1 (unknown)
ipv6.dhcp-send-hostname:                yes
ipv6.dhcp-hostname:                     --
Comment 15 Jirka Klimes 2015-09-25 08:34:42 EDT
*** Bug 1264432 has been marked as a duplicate of this bug. ***
Comment 16 Justin W. Flory 2015-10-23 15:37:57 EDT
Another user experienced a similar problem:

This occurred while I was trying to use GNOME Boxes to make a Fedora virtual machine. It appears that there are severe issues on this device whenever I try to use Boxes for virtualization, and this time was the most severe of past events.

Steps:
1) Create virtual machine in Boxes
2) Wait while it starets up
3) Computer becomes slow and unresponsive, does not respond to clicks or keyboard presses
4) GNOME shell crashes
5) Later followed by NetworkManager and then systemd crashing (thereby logging me out)

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/sbin/NetworkManager --no-daemon
crash_function: nm_device_activate_stage3_ip4_start
executable:     /usr/sbin/NetworkManager
global_pid:     1086
kernel:         4.2.3-300.fc23.x86_64
package:        NetworkManager-1.0.6-7.fc23
reason:         NetworkManager killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            0
Comment 17 jaroslaw.herod 2015-11-19 11:44:42 EST
Another user experienced a similar problem:

not sure what happen

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/sbin/NetworkManager --no-daemon
crash_function: nm_device_activate_stage3_ip4_start
executable:     /usr/sbin/NetworkManager
global_pid:     1330
kernel:         4.2.5-300.fc23.x86_64
package:        NetworkManager-1.0.6-7.fc23
reason:         NetworkManager killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            0
Comment 18 Beniamino Galvani 2016-01-05 04:32:05 EST
Already fixed in 1.0.8 with commit:

http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=d19cbabc141f485549a1eb7dbf94d167e3cbfa2e

"nm-device: only progress with ip-config if the device is still in IP_WAIT"

Note You need to log in before you can comment on or make changes to this bug.