Bug 1262921 - Fix for "Do not segv if NULL is passed for CTX..."
Fix for "Do not segv if NULL is passed for CTX..."
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libassuan (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 11:48 EDT by Rex Dieter
Modified: 2015-10-05 18:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.3.0-1.fc22 libassuan-2.3.0-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-24 04:24:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 349637 None None None Never

  None (edit)
Description Rex Dieter 2015-09-14 11:48:28 EDT
kdepim upstream has requested we backport a libassuan fix:
http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libassuan.git;a=commit;h=0da6afa864cfd68333941d6332d762c82928946c

That is the cause of some upstream bug reports (crashing),
http://bugs.kde.org/349637

It would appear this fix went in after libassuan-2.2.1 (included in libassuan-2.3.0 release), so affects f21's libassuan-2.1.0-5.fc21 and f22's libassuan-2.2.0-1.fc22

I can help implement the fixed in fedora's packaging, if you have preference on how best to handle it:

* libassuan-2.3.0 in f23 (and newer) branches are presumably binary-compatible (using the same library soname), so easiest fix would be to merge back to f22/f21 branches to release libassuan-2.3.0 there too

* backport/cherry-pick the specific upstream commit, and apply to existing version packaging
Comment 1 Tomas Mraz 2015-09-15 05:08:06 EDT
I think update to 2.3.0 should be fine. I'll prepare the update.
Comment 2 Fedora Update System 2015-09-15 05:36:36 EDT
libassuan-2.3.0-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15883
Comment 3 Rex Dieter 2015-09-15 08:04:25 EDT
Thanks
Comment 4 Fedora Update System 2015-09-15 18:54:30 EDT
libassuan-2.3.0-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update libassuan'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15882
Comment 5 Fedora Update System 2015-09-15 18:56:22 EDT
libassuan-2.3.0-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update libassuan'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15883
Comment 6 Fedora Update System 2015-09-24 04:24:53 EDT
libassuan-2.3.0-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2015-10-05 18:52:35 EDT
libassuan-2.3.0-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.