Bug 1262940 - Package installs report successful when they have failed on the client
Package installs report successful when they have failed on the client
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
6.1.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Stephen Benjamin
Katello QA List
: Triaged
: 1223029 1261753 1293984 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 12:47 EDT by Stephen Benjamin
Modified: 2017-09-27 04:56 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-26 13:23:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Benjamin 2015-09-14 12:47:37 EDT
Description of problem:
Attempting to install or upgrade a package reports as successful even if the package was not installed.

Version-Release number of selected component (if applicable):
6.1.1

How reproducible:
Always

Steps to Reproduce:
1. In the UI, on the Packages tab of a host, enter something nonsensical like "aadfjkasrghje"
2. Click Perform

Actual results:
Task succeeds, with message: "No package(s) available to install"


Expected results:
Task should fail


Additional info:
Comment 1 Stephen Benjamin 2015-09-14 12:49:00 EDT
*** Bug 1261753 has been marked as a duplicate of this bug. ***
Comment 2 Stephen Benjamin 2015-09-23 15:13:03 EDT
It appears to the same case for any failure, e.g. installing a package without a GPG key available on the host.
Comment 4 Jeff Ortel 2016-01-28 10:21:50 EST
The information needed by katello to fix this is contained in the 'result' part of the Pulp task.
Comment 6 Ivan Necas 2016-04-25 04:50:35 EDT
*** Bug 1293984 has been marked as a duplicate of this bug. ***
Comment 7 Ivan Necas 2016-04-25 04:56:39 EDT
*** Bug 1223029 has been marked as a duplicate of this bug. ***
Comment 10 Chris Duryee 2016-09-26 13:23:06 EDT
checked against 6.2.0

When attempting to repro per #0, I got the expected error:

*:asdfasdf-*-*.*: No package(s) available to install

Note You need to log in before you can comment on or make changes to this bug.