Bug 1262953 - FileNotFoundError: [Errno 2] No such file or directory: 'systemctl'
FileNotFoundError: [Errno 2] No such file or directory: 'systemctl'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:d2bd0b532bb3590ef5316fa7248...
:
: 1263944 1266170 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 13:58 EDT by A.J. Werkman
Modified: 2016-08-25 15:43 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-25 15:43:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.09 MB, text/plain)
2015-09-14 13:58 EDT, A.J. Werkman
no flags Details
File: anaconda.log (44.69 KB, text/plain)
2015-09-14 13:58 EDT, A.J. Werkman
no flags Details
File: dnf.log (151.49 KB, text/plain)
2015-09-14 13:58 EDT, A.J. Werkman
no flags Details
File: dnf.rpm.log (261.37 KB, text/plain)
2015-09-14 13:58 EDT, A.J. Werkman
no flags Details
File: environ (459 bytes, text/plain)
2015-09-14 13:58 EDT, A.J. Werkman
no flags Details
File: lsblk_output (2.62 KB, text/plain)
2015-09-14 13:58 EDT, A.J. Werkman
no flags Details
File: nmcli_dev_list (1.13 KB, text/plain)
2015-09-14 13:59 EDT, A.J. Werkman
no flags Details
File: os_info (451 bytes, text/plain)
2015-09-14 13:59 EDT, A.J. Werkman
no flags Details
File: program.log (118.12 KB, text/plain)
2015-09-14 13:59 EDT, A.J. Werkman
no flags Details
File: storage.log (168.92 KB, text/plain)
2015-09-14 13:59 EDT, A.J. Werkman
no flags Details
File: syslog (94.63 KB, text/plain)
2015-09-14 13:59 EDT, A.J. Werkman
no flags Details
File: ifcfg.log (2.31 KB, text/plain)
2015-09-14 13:59 EDT, A.J. Werkman
no flags Details
File: packaging.log (3.21 KB, text/plain)
2015-09-14 13:59 EDT, A.J. Werkman
no flags Details

  None (edit)
Description A.J. Werkman 2015-09-14 13:58:42 EDT
Description of problem:
Basic Server install

Version-Release number of selected component:
anaconda-23.19.3-1

The following was filed automatically by anaconda:
anaconda 23.19.3-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/subprocess.py", line 1457, in _execute_child
    raise child_exception_type(errno_num, err_msg)
  File "/usr/lib64/python3.4/subprocess.py", line 859, in __init__
    restore_signals, start_new_session)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 201, in startProgram
    preexec_fn=preexec, cwd=root, env=env, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 279, in _run_program
    env_prune=env_prune)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 358, in execWithRedirect
    log_output=log_output, binary_output=binary_output)[0]
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 336, in execInSysroot
    return execWithRedirect(command, argv, stdin=stdin, root=getSysroot())
  File "/usr/lib64/python3.4/site-packages/pyanaconda/kickstart.py", line 1653, in execute
    iutil.execInSysroot("systemctl", ["enable", svc])
  File "/usr/lib64/python3.4/site-packages/pyanaconda/install.py", line 79, in doConfiguration
    ksdata.services.execute(storage, ksdata, instClass)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
FileNotFoundError: [Errno 2] No such file or directory: 'systemctl'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz noselinux ip=172.18.92.70::172.18.92.65:255.255.255.192:cfl.lc.digifarma.nl::off noipv6 nameserver=172.18.92.65 inst.stage2=hd:UUID=c98f6f60-f5fe-4bf9-b500-8e918649636a
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23
Comment 1 A.J. Werkman 2015-09-14 13:58:48 EDT
Created attachment 1073377 [details]
File: anaconda-tb
Comment 2 A.J. Werkman 2015-09-14 13:58:50 EDT
Created attachment 1073378 [details]
File: anaconda.log
Comment 3 A.J. Werkman 2015-09-14 13:58:52 EDT
Created attachment 1073379 [details]
File: dnf.log
Comment 4 A.J. Werkman 2015-09-14 13:58:55 EDT
Created attachment 1073380 [details]
File: dnf.rpm.log
Comment 5 A.J. Werkman 2015-09-14 13:58:57 EDT
Created attachment 1073381 [details]
File: environ
Comment 6 A.J. Werkman 2015-09-14 13:58:59 EDT
Created attachment 1073382 [details]
File: lsblk_output
Comment 7 A.J. Werkman 2015-09-14 13:59:00 EDT
Created attachment 1073383 [details]
File: nmcli_dev_list
Comment 8 A.J. Werkman 2015-09-14 13:59:01 EDT
Created attachment 1073384 [details]
File: os_info
Comment 9 A.J. Werkman 2015-09-14 13:59:03 EDT
Created attachment 1073385 [details]
File: program.log
Comment 10 A.J. Werkman 2015-09-14 13:59:05 EDT
Created attachment 1073386 [details]
File: storage.log
Comment 11 A.J. Werkman 2015-09-14 13:59:07 EDT
Created attachment 1073387 [details]
File: syslog
Comment 12 A.J. Werkman 2015-09-14 13:59:09 EDT
Created attachment 1073388 [details]
File: ifcfg.log
Comment 13 A.J. Werkman 2015-09-14 13:59:10 EDT
Created attachment 1073389 [details]
File: packaging.log
Comment 14 David Shea 2015-09-14 14:19:08 EDT
Sep 15 11:04:40 CRIT systemd-222-2.fc23.x86_64 was supposed to be installed but is not!

I have no idea how it happened, but based on dnf.log your rpm transaction got hosed.
Comment 15 A.J. Werkman 2015-09-14 14:37:12 EDT
The error shows when installing from a network repo. I checked and the package is there. From the http log I found that the package is downloaded during the installation process.

After that I reproduced this in an installation from the server dvd iso images.

Can I conclude that the package is not corrupt?
Comment 16 A.J. Werkman 2015-09-14 16:36:01 EDT
It looks like this error is relating to a problem in installing the efi bootloader, as I see a message saying there might be aproblem in kernel or firmware that may give a problem in installing the bootloader. With this message the error occupeer. Without this message I don't see the error.
Comment 17 Vojtech Trefny 2015-09-17 03:42:44 EDT
*** Bug 1263944 has been marked as a duplicate of this bug. ***
Comment 18 A.J. Werkman 2015-09-19 15:19:31 EDT
This error is a regression from Beta_23_TC1, where it does not occure.

The error is related to the 'noselinux' cli parameter. Without 'noselinux' Fedora installs without a problem.
Comment 19 Michal Luscon 2015-09-21 05:32:48 EDT
Does not look like dnf issue => reassigning back to anaconda.
Comment 20 David Shea 2015-09-21 16:24:14 EDT
(In reply to Michal Luscon from comment #19)
> Does not look like dnf issue => reassigning back to anaconda.

What would cause all of the "<package> was supposed to be installed but is not!" messages, then?
Comment 21 David Shea 2015-09-24 14:03:50 EDT
Assigning back to dnf since it is absolutely a dnf issue to either install the packages requested or raise an exception.
Comment 22 Michal Luscon 2015-09-25 05:24:05 EDT
Ok, I mistakenly supposed that you expected packages to be installed. The whole responsibility of transaction processing is on RPM and unfortunately, it does not provide any useful error information to DNF in this case.

Florian, I would guess this is similar to the issue which we had discussed on IRC recently (see comment #18).
Comment 23 Florian Festi 2015-09-25 05:52:43 EDT
Looks like this is cause by the failing scriptlets. RPM skips the installation of packages if the PREIN scriptlet fails. Unfortunately I did not find any error message from the scriptlet themselves. As a large number of scriptlets fails it is likely that the install root is broken in some important way - like not having /proc mounted.
Comment 24 Honza Silhan 2015-10-02 05:59:24 EDT
*** Bug 1266170 has been marked as a duplicate of this bug. ***
Comment 25 Florian Festi 2016-02-19 07:06:58 EST
Is this still broken? I think we fixed that somehow but I can't find the fix right now...

Note You need to log in before you can comment on or make changes to this bug.