Bug 12630 - my DDC monitor is not detected properly
my DDC monitor is not detected properly
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-19 13:41 EDT by David Balažic
Modified: 2007-03-26 23:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-31 09:42:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Just testing attachment creation (4.36 KB, text/plain)
2000-06-20 03:56 EDT, David Balažic
no flags Details
ddcprobe output for SUN CM751U (2.72 KB, text/plain)
2000-08-31 09:42 EDT, David Balažic
no flags Details

  None (edit)
Description David Balažic 2000-06-19 13:41:14 EDT
This or more or less the same as bug #9633.

During a gfx mode install from a CD my monitor is not properly detected.
There is an entry in the 'DDC Probed monitor' line named :
'HEI769b' , but he values are :
Horizontal : 60 , vertical : 31.5
That is first obviusly swapped around and second is not even near the 
monitors specs.
The monitor data obtained by PowerStrip under windows is :
--
Hyundai HT-7695B
max hor sync : 95kHz , max ver sync 150 Hz
EDID version 1.0
Model ID HEI769B
--

I also attached the output of ddcprobe.
Comment 1 David Balažic 2000-06-19 13:54:25 EDT
As attaching somehow doesn't work , I'm posting the ddcprobe output here:

VESA 3.0 detected.
OEM Name: NVidia
Vendor Name: NVidia
Product Name: Riva TNT
Product Revision: A0
Memory installed = 252 * 64k blocks = 16128kb
Supported standard modes:
        640x400x256
        640x480x256
        800x600x16
        800x600x256
        1024x768x16
        1024x768x256
        1280x1024x16
        1280x1024x256
        80x60 (text)
        132x25 (text)
        132x43 (text)
        132x50 (text)
        132x60 (text)
        320x200x64k
        320x200x16m
        640x480x64k
        640x480x16m
        800x600x64k
        800x600x16m
        1024x768x64k
        1024x768x16m
        1280x1024x64k
EDID ver. 1 rev. 0.
Manufacturer: HEI
ID: 769b
EISA ID: HEI769b
Serial number: 00000814.
Manufactured in week 8 of 1999.
Input signal type: sync on green, analog signal.
Screen size max 32 cm horizontal, 24 cm vertical.
Gamma: 2.000000.
DPMS flags: RGB, active off, suspend, standby.
Established timings:
        720x400 @ 70 Hz (VGA 640x400, IBM)
        640x480 @ 75 Hz (VESA)
        800x600 @ 60 Hz (VESA)
        800x600 @ 72 Hz (VESA)
        800x600 @ 75 Hz (VESA)
        1024x768 @ 87 Hz Interlaced (8514A)
        1024x768 @ 75 Hz (VESA)
Standard timing 0: 85 Hz, 640x480
Standard timing 1: 85 Hz, 800x600
Standard timing 2: 85 Hz, 1024x768
Standard timing 3: 60 Hz, 1280x960
Standard timing 4: 85 Hz, 1280x960
Standard timing 5: 60 Hz, 1600x1200
Standard timing 6: 75 Hz, 1600x1200
Detailed timing 0:
        Pixel clock: 55000000
        Horizontal active time (pixel width): 128
        Horizontal blank time (pixel width): 736
        Vertical active time (pixel height): 224
        Vertical blank time (pixel height): 306
        Horizontal sync offset: 32
        Horizontal sync pulse width: 96
        Vertical sync offset: 6
        Vertical sync pulse width: 8
        Dimensions: 64x496
Detailed timing 1:
        Pixel clock: 94800000
        Horizontal active time (pixel width): 256
        Horizontal blank time (pixel width): 1120
        Vertical active time (pixel height): 0
        Vertical blank time (pixel height): 808
        Horizontal sync offset: 48
        Horizontal sync pulse width: 96
        Vertical sync offset: 3
        Vertical sync pulse width: 1
        Dimensions: 64x496
Detailed timing 2:
        Pixel clock: 157500000
        Horizontal active time (pixel width): 256
        Horizontal blank time (pixel width): 1472
        Vertical active time (pixel height): 0
        Vertical blank time (pixel height): 1072
        Horizontal sync offset: 64
        Horizontal sync pulse width: 160
        Vertical sync offset: 3
        Vertical sync pulse width: 1
        Dimensions: 64x496
Detailed timing 3:
        Pixel clock: 202500000
        Horizontal active time (pixel width): 576
        Horizontal blank time (pixel width): 1584
        Vertical active time (pixel height): 176
  Vertical blank time (pixel height): 1074
        Horizontal sync offset: 64
        Horizontal sync pulse width: 192
        Vertical sync offset: 3
        Vertical sync pulse width: 1
        Dimensions: 64x496
Comment 2 David Balažic 2000-06-20 03:56:53 EDT
Created attachment 619 [details]
Just testing attachment creation
Comment 3 David Balažic 2000-07-03 06:10:14 EDT
Same in beta2.
Comment 4 Glen Foster 2000-07-18 15:11:36 EDT
This defect is considered MUST-FIX for Winston Beta-5
Comment 5 Glen Foster 2000-07-21 14:40:32 EDT
Does this defect still exist with (on) Winston beta-4?
Comment 6 Michael Fulbright 2000-07-27 14:35:24 EDT
Is this fixed in beta 5?
Comment 7 David Balažic 2000-08-16 05:31:58 EDT
Now ( beta5 ) the detected values are 40-95 and 50-150,
while they really should be 30-95 and 50-150.
Close, but still...

And the monitor appears under Hyundai and
not DDC-probed as before. Is that normal ?
Comment 8 David Balažic 2000-08-22 08:16:45 EDT
It is OK now in RC1.
Someone mark it as RESOLVED.
Comment 9 David Balažic 2000-08-31 09:34:51 EDT
Still not 100% OK ( RC1 ).

When booting the RC1 CD X11 comes up with 85 Hz vertical refresh,
meaning that it detected the monitor through DDC ( otherwise is uses
60 Hz ). But if I reboot and start all over it won't recognize it any
more. What's more , not even windows 98 will recognize it any more.
By turning the monitor off and back fixes it.

Looks like the DDC probing in anaconda somehow screws up the monitor.

I remember reading somewhere that after being queried in DDC2 mode,
the monitor will not answer DDC1 queries until reboot.
Maybe this is related.

I really need help about this, because I was thinking to send the
monitor to service, but then I discovered that only RH7 install CD
makes this problems, so I'm not sure anymore if the monitor is gone
bad or not.
Comment 10 David Balažic 2000-08-31 09:36:48 EDT
Another monitor is misdetected by RC1 installer.
This one is SUN CM751U.
The ddcprobe output is attached.
Comment 11 David Balažic 2000-08-31 09:42:23 EDT
Created attachment 3120 [details]
ddcprobe output for SUN CM751U

Note You need to log in before you can comment on or make changes to this bug.