Bug 1263023 - Badly formatted puppet module uploads appear successful via UI/hammer
Badly formatted puppet module uploads appear successful via UI/hammer
Status: CLOSED DUPLICATE of bug 1234619
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories (Show other bugs)
Unspecified
All Linux
medium Severity medium (vote)
: GA
: --
Assigned To: John Mitsch
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 19:28 EDT by Mike McCune
Modified: 2016-05-02 13:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-02 13:49:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1614283 None None None Never

  None (edit)
Description Mike McCune 2015-09-14 19:28:35 EDT
Puppet modules that are improperly formatted with either compression format or json manifest still show a successful upload in the UI even thou they fail in the background.

1) create an invalid puppet module file, eg take a zipfile with random content or zip up an existing puppet module tar.gz into a .zip file which Pulp does not know how to process.

2) attempt to upload via hammer or the UI

3) note success in UI/hammer

4) note error in logs:

pulp_puppet.plugins.importers.importer:ERROR: (3109-65920) InvalidTarball: Invalid properties: ['/var/lib/pulp/uploads/66437536-c822-45c4-992d-e2bfeddb4945']
Sep  7 22:31:48 jnikolaksat6rhel6 pulp: celery.worker.job:INFO: Task
Comment 2 David Davis 2016-05-02 13:49:32 EDT

*** This bug has been marked as a duplicate of bug 1234619 ***

Note You need to log in before you can comment on or make changes to this bug.