Bug 1263054 - Mock tries to use dnf by default
Mock tries to use dnf by default
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: mock (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 23:52 EDT by Susi Lehtola
Modified: 2016-09-23 04:05 EDT (History)
6 users (show)

See Also:
Fixed In Version: mock-1.2.21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-23 04:05:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Susi Lehtola 2015-09-14 23:52:43 EDT
The default configuration of mock in EL6 and EL7 tries to use dnf in newer Fedora buildroots. Naturally, this ends in a crash, because dnf is not available on EL6.

While the workaround has been documented at
 https://fedoraproject.org/wiki/Mock#Mock_on_EL_6_and_EL_7:_Yum.2C_and_DNF
I am surprised this is not included in the default config.

The default config in EL6 and EL7 for F23 and rawhide should be modified so that yum is called instead of dnf so that mock works properly. [Yes, I am aware that there may be small differences in the result due to different dependency satisfaction between yum and dnf, but it's better that it works in 99% of cases than fails in 100% of cases.]
Comment 1 Miroslav Suchý 2015-09-15 02:51:52 EDT
This has been done in commit 45beb2e. In next version Mock will emit warning. Wait for confirmation, suggest you how to get rid off this warning next time and eventually proceed. But will not fail.
Comment 2 Miroslav Suchý 2016-09-23 04:05:31 EDT
This somehow went off the radar. This fix is already in mock-1.2.21, which is either in updates or in stable.

Note You need to log in before you can comment on or make changes to this bug.