Bug 1263163 - [RFE] hosted-engine should support migration of self-hosted engine to other host
[RFE] hosted-engine should support migration of self-hosted engine to other host
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: RFEs (Show other bugs)
---
Unspecified Unspecified
unspecified Severity low (vote)
: ---
: ---
Assigned To: bugs@ovirt.org
meital avital
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 04:52 EDT by Jiri Belka
Modified: 2016-08-11 04:42 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-11 04:42:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑future?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2015-09-15 04:52:18 EDT
Description of problem:
hosted-engine should support migration of self-hosted engine to other host. why? for unknown reason now (probably timeout, high usage) i could not migrate self-hosted engine inside its own engine admin portal. the migration was always in 95, 98, 95, 98 and them got

  Migration failed due to Error: Migration not in progress

we got an idea to stop engine so memory of the VM is not changing to we could migrate it easily but then... there is no way how to migrate the VM without engine.

i suppose there should be hosted-engine --migrate-vm or something like this.

has self-hosted engine been tested fully when hosting hundreds of VMs and having many concurrent logins into admin portal? could you migrate it successfully?

Version-Release number of selected component (if applicable):
3.5.4

How reproducible:
??? (100% on our env)

Steps to Reproduce:
1. have self-hosted engine on 2 nodes
2. engine has 2 nodes in DC and has many VMs in same DC
3. make big load on engine VM

Actual results:
stop engine daemon and try to migrate the VM without running engine daemon

Expected results:
not possible, maybe manual qemu kung-fu but that's not very user friendly

Additional info:
Comment 1 Yaniv Kaul 2015-09-16 01:45:56 EDT
(In reply to Jiri Belka from comment #0)
> has self-hosted engine been tested fully when hosting hundreds of VMs and
> having many concurrent logins into admin portal? could you migrate it
> successfully?

Who are you asking here?


> Additional info:

- Is it any different than a regular VM migration failure, that fails to converge? 
- Where are all the relevant logs?
Comment 2 Sandro Bonazzola 2015-09-16 08:54:28 EDT
Not a setup issue. Moving to vdsm for the migration handling.
Comment 3 Sandro Bonazzola 2015-09-16 08:55:32 EDT
Also probably not a RFE but a real bug.
Comment 4 Jiri Belka 2015-09-21 04:23:06 EDT
(In reply to Yaniv Kaul from comment #1)
> (In reply to Jiri Belka from comment #0)
> > has self-hosted engine been tested fully when hosting hundreds of VMs and
> > having many concurrent logins into admin portal? could you migrate it
> > successfully?
> 
> Who are you asking here?

...

> > Additional info:
> 
> - Is it any different than a regular VM migration failure, that fails to
> converge?

Yes, there's no running engine which manage the migration.

> - Where are all the relevant logs?

This is RFE, thus no logs.
Comment 5 Yaniv Kaul 2015-09-21 04:26:19 EDT
(In reply to Jiri Belka from comment #4)
> (In reply to Yaniv Kaul from comment #1)
> > (In reply to Jiri Belka from comment #0)
> > > has self-hosted engine been tested fully when hosting hundreds of VMs and
> > > having many concurrent logins into admin portal? could you migrate it
> > > successfully?
> > 
> > Who are you asking here?
> 
> ...

QE? 

> 
> > > Additional info:
> > 
> > - Is it any different than a regular VM migration failure, that fails to
> > converge?
> 
> Yes, there's no running engine which manage the migration.
> 
> > - Where are all the relevant logs?
> 
> This is RFE, thus no logs.

So what? It'd be easier to find where it gets stuck - in case it should have migrated and where it should have been blocked from migrating - if it's not a supported scenario.
Comment 6 Yaniv Lavi 2016-06-28 10:03:37 EDT

*** This bug has been marked as a duplicate of bug 1216190 ***
Comment 7 Jiri Belka 2016-06-28 10:24:12 EDT
(In reply to Yaniv Dary from comment #6)
> 
> *** This bug has been marked as a duplicate of bug 1216190 ***

In fact this could not be duplicate as BZ1216190 is about storage live migration.
Comment 8 Yaniv Lavi 2016-06-28 10:29:10 EDT
(In reply to Jiri Belka from comment #7)
> (In reply to Yaniv Dary from comment #6)
> > 
> > *** This bug has been marked as a duplicate of bug 1216190 ***
> 
> In fact this could not be duplicate as BZ1216190 is about storage live
> migration.

Sorry reopening.
Comment 9 Doron Fediuck 2016-07-17 04:36:10 EDT
Live migration of HE is working today.
Please let us know if anything else is needed (or close current release).
Comment 10 Jiri Belka 2016-07-22 10:29:16 EDT
(In reply to Doron Fediuck from comment #9)
> Live migration of HE is working today.
> Please let us know if anything else is needed (or close current release).

there is no option in hosted-engine command to migrate the HE VM. it would be nice to have such feature as engine itself can be buggy and can prevent migration of HE VM because of incorrent handling of hosts.
Comment 11 Yedidyah Bar David 2016-07-24 02:24:28 EDT
(In reply to Jiri Belka from comment #10)
> (In reply to Doron Fediuck from comment #9)
> > Live migration of HE is working today.
> > Please let us know if anything else is needed (or close current release).
> 
> there is no option in hosted-engine command to migrate the HE VM. it would
> be nice to have such feature as engine itself can be buggy and can prevent
> migration of HE VM because of incorrent handling of hosts.

IIRC if you have a host running the engine vm, and run 'hosted-engine --set-maintenance --mode=local', it will migrate the vm first.
Comment 12 Jiri Belka 2016-08-11 03:59:22 EDT
OK, this was working during my last testing. Feel free to close this BZ. Thank you.
Comment 13 Yedidyah Bar David 2016-08-11 04:42:55 EDT
Closing based on comment 12.

Note You need to log in before you can comment on or make changes to this bug.