Bug 1263196 - Error polling connection 'qemu:///system': internal error: client socket is closed
Error polling connection 'qemu:///system': internal error: client socket is c...
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 06:00 EDT by jean-christophe manciot
Modified: 2015-09-15 11:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-15 11:37:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jean-christophe manciot 2015-09-15 06:00:12 EDT
Description of problem:
----------------------
Traceback (most recent call last):
  File "/home/actionmystique/Program-Files/Ubuntu/Virt-manager/git-virt-manager/virtManager/engine.py", line 343, in _handle_tick_queue
    conn.tick_from_engine(**kwargs)
  File "/home/actionmystique/Program-Files/Ubuntu/Virt-manager/git-virt-manager/virtManager/connection.py", line 1275, in tick_from_engine
    raise e  # pylint: disable=raising-bad-type
libvirtError: internal error: client socket is closed

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
Latest git sources or stable tarball (1.2.1)

How reproducible:
----------------
Install libvirt 1.2.19 & launch virt-manager

Additional info:
---------------
Ubuntu Server 15.04
Libvirtd seems OK:

root@msi-ge60-ubuntu:/home/actionmystique/Program-Files/Ubuntu/Virt-manager# systemctl status libvirt-bin
● libvirt-bin.service - Virtualization daemon
   Loaded: loaded (/lib/systemd/system/libvirt-bin.service; enabled; vendor preset: enabled)
   Active: activating (start) since Tue 2015-09-15 11:55:42 CEST; 1min 4s ago
     Docs: man:libvirtd(8)
           http://libvirt.org
 Main PID: 16729 (libvirtd)
   CGroup: /system.slice/libvirt-bin.service
           ├─ 2611 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-8.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 2612 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-8.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 2767 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_leaseshelp...
           ├─ 2768 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_leaseshelp...
           ├─ 2822 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-6.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 2823 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-6.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 2878 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/loopback.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_leaseshel...
           ├─ 2879 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/loopback.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_leaseshel...
           ├─ 2933 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-1.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 2934 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-1.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 3082 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-2.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 3083 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-2.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 3270 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-5.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 3271 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-5.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 3328 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-4.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 3329 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-4.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 3387 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-router.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_lea...
           ├─ 3388 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-router.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_lea...
           ├─ 3442 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-9.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 3443 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-9.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 3503 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-7.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 3504 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-7.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 3566 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-3.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─ 3567 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-3.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           └─16729 /usr/sbin/libvirtd

Sep 15 11:55:43 msi-ge60-ubuntu dnsmasq[2611]: read /var/lib/libvirt/dnsmasq/virtual-bridge-8.addnhosts - 0 addresses
Sep 15 11:55:43 msi-ge60-ubuntu dnsmasq[2767]: read /var/lib/libvirt/dnsmasq/default.addnhosts - 0 addresses
Sep 15 11:55:43 msi-ge60-ubuntu dnsmasq[2933]: read /var/lib/libvirt/dnsmasq/virtual-bridge-1.addnhosts - 0 addresses
Sep 15 11:55:43 msi-ge60-ubuntu dnsmasq[3566]: read /var/lib/libvirt/dnsmasq/virtual-bridge-3.addnhosts - 0 addresses
Sep 15 11:55:43 msi-ge60-ubuntu dnsmasq-dhcp[3270]: read /var/lib/libvirt/dnsmasq/virtual-bridge-5.hostsfile
Sep 15 11:55:43 msi-ge60-ubuntu dnsmasq-dhcp[3082]: read /var/lib/libvirt/dnsmasq/virtual-bridge-2.hostsfile
Sep 15 11:55:43 msi-ge60-ubuntu dnsmasq-dhcp[2611]: read /var/lib/libvirt/dnsmasq/virtual-bridge-8.hostsfile
Sep 15 11:55:43 msi-ge60-ubuntu dnsmasq-dhcp[2767]: read /var/lib/libvirt/dnsmasq/default.hostsfile
Sep 15 11:55:43 msi-ge60-ubuntu dnsmasq-dhcp[2933]: read /var/lib/libvirt/dnsmasq/virtual-bridge-1.hostsfile
Sep 15 11:55:43 msi-ge60-ubuntu dnsmasq-dhcp[3566]: read /var/lib/libvirt/dnsmasq/virtual-bridge-3.hostsfile
Comment 1 Cole Robinson 2015-09-15 09:35:42 EDT
This is likely a libvirt problem, that error is coming from libvirt. Usually it means the daemon is crashing but something else must be going on since systemd isn't reporting any errors

Is this libvirt compiled from source, or distro package?
Did you try the distro version of virt-manager? It will probably hit the same issue
Comment 2 jean-christophe manciot 2015-09-15 11:37:28 EDT
Yes, you're right, I have been investing it inside libvirt (compiled from sources) in the meantime: libvirtd is constantly starting, failing & starting again. Since the timeout is a little long, it is difficult to notice unless one has an acute awareness of systemd messages: "activating (start)" is quite different from "active (running)" ;)

Anyway, the issue comes from Ubuntu: reverting back to their 1.2.12 specific files from 1.2.16 allows me to start libvirtd (actually libvirt-bin as they like to call it):

root@msi-ge60-ubuntu:/home/actionmystique/Program-Files/Ubuntu/Libvirt# systemctl status libvirt-bin
● libvirt-bin.service - LSB: libvirt management daemon
   Loaded: loaded (/etc/init.d/libvirt-bin)
   Active: active (running) since Tue 2015-09-15 17:26:42 CEST; 6s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 29371 ExecStart=/etc/init.d/libvirt-bin start (code=exited, status=0/SUCCESS)
 Main PID: 11273 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/libvirt-bin.service
           ├─29377 /usr/sbin/libvirtd -d
           ├─29812 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-router.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_lea...
           ├─29813 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-router.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_lea...
           ├─29820 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-6.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29821 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-6.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29828 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-9.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29829 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-9.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29837 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-5.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29838 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-5.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29847 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-1.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29848 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-1.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29856 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_leaseshelp...
           ├─29857 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_leaseshelp...
           ├─29864 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-2.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29865 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-2.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29872 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-7.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29873 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-7.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29880 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-3.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29881 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-3.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29888 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/loopback.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_leaseshel...
           ├─29889 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/loopback.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_leaseshel...
           ├─29899 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-8.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29900 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-8.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           ├─29907 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-4.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...
           └─29908 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-4.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_l...

Sep 15 17:26:44 msi-ge60-ubuntu dnsmasq[29907]: compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset...p-detect
Sep 15 17:26:44 msi-ge60-ubuntu dnsmasq[29907]: warning: no upstream servers configured
Sep 15 17:26:44 msi-ge60-ubuntu dnsmasq-dhcp[29907]: DHCP, IP range 172.22.100.128 -- 172.22.100.254, lease time 1h
Sep 15 17:26:44 msi-ge60-ubuntu dnsmasq-dhcp[29907]: DHCPv6, IP range fc22:100::100 -- fc22:100::1ff, lease time 1h
Sep 15 17:26:44 msi-ge60-ubuntu dnsmasq-dhcp[29907]: router advertisement on fc22:100::
Sep 15 17:26:44 msi-ge60-ubuntu dnsmasq-dhcp[29907]: IPv6 router advertisement enabled
Sep 15 17:26:44 msi-ge60-ubuntu dnsmasq-dhcp[29907]: DHCP, sockets bound exclusively to interface virbr6
Sep 15 17:26:44 msi-ge60-ubuntu dnsmasq[29907]: read /etc/hosts - 7 addresses
Sep 15 17:26:44 msi-ge60-ubuntu dnsmasq[29907]: read /var/lib/libvirt/dnsmasq/virtual-bridge-4.addnhosts - 0 addresses
Sep 15 17:26:44 msi-ge60-ubuntu dnsmasq-dhcp[29907]: read /var/lib/libvirt/dnsmasq/virtual-bridge-4.hostsfile

Note You need to log in before you can comment on or make changes to this bug.