Bug 1263228 - Unable to change cluster version in empty cluster
Unable to change cluster version in empty cluster
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-3.6.0-ga
: 3.6.0
Assigned To: Eli Mesika
Pavel Novotny
infra
:
: 1263329 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 07:25 EDT by Martin Perina
Modified: 2016-02-10 14:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 06:17:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.0?
rule-engine: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
engine.log (49.64 KB, text/plain)
2015-09-15 07:27 EDT, Martin Perina
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45867 ovirt-engine-3.6 MERGED core:fix NPE on edit empty cluster version Never

  None (edit)
Description Martin Perina 2015-09-15 07:25:55 EDT
Description of problem:

If you want to change cluster compatibility version in empty cluster, dialog stays open and no action is performed. In browser console you can see error:

WARNING: Failure while invoking runQuery [null, ] 158A4F02F051587DBBAA8779A2F1F844.cache.html:23322:3

Version-Release number of selected component (if applicable):

3.6 and master

How reproducible:

100%

Steps to Reproduce:
1. Create new cluster with compatibility version 3.5
2. Try to change cluster version to 3.6
3.

Actual results:

Nothing happens, warning in browser console

Expected results:

Changing cluster compatibility version works fine

Additional info:
Comment 1 Martin Perina 2015-09-15 07:27:21 EDT
Created attachment 1073593 [details]
engine.log
Comment 2 Martin Betak 2015-09-16 06:15:39 EDT
*** Bug 1263329 has been marked as a duplicate of this bug. ***
Comment 3 Pavel Novotny 2015-09-18 11:00:25 EDT
Verified in rhevm-3.6.0-0.16.master.el6.noarch (build 3.6.0-13).

Verification steps: 
A) Followed reproducer from comment 0: 
1. Create new cluster with compatibility version 3.5
2. Try to change cluster version to 3.6

B) Also followed reproducer from bug 1263329 comment 0:
1. Clean installation of RHEVM 3.6.
2. Log into webadmin, go to Clusters tab and create a cluster. Fill in whatever values you like.
3. Then edit the cluster and submit the dialog. It doesn't matter if you change any values there or not.

Result: Cluster parameters have been always successfully updated.
Comment 4 Red Hat Bugzilla Rules Engine 2015-10-18 04:21:48 EDT
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 5 Sandro Bonazzola 2015-11-04 06:17:20 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.