Bug 1263298 - gdeploy: add-brick fails with fresh devices
gdeploy: add-brick fails with fresh devices
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Sachidananda Urs
Anush Shetty
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 09:57 EDT by Anush Shetty
Modified: 2015-09-15 10:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-15 10:17:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2015-09-15 09:57:40 EDT
Description of problem: When the bricks to be added through add-brick operation to a volume also need a fresh backend setup, gdeploy fails.

gdeploy add-brick operations works only when there is an existing brick mounts on the hosts. 

Version-Release number of selected component (if applicable): gdeploy-1.0-11.el7rhs.noarch


How reproducible: Always

Steps to Reproduce:
1. Create a config file for setting up bricks and doing an add-brick:

[hosts]
rhshdp03.lab.eng.blr.redhat.com
rhshdp04.lab.eng.blr.redhat.com
rhshdp05.lab.eng.blr.redhat.com
rhshdp06.lab.eng.blr.redhat.com

[devices]                                                         /dev/vdc                                                                                                                                                        
[mountpoints]
/gluster1/brick1/

[brick_dirs]
/gluster1/brick1/s1

[peer]
manage=probe

[tune-profile]
none

[volume]
action=add-brick
volname=rhshdp03.lab.eng.blr.redhat.com:vol2
replica=yes
replica_count=2
bricks=rhshdp05.lab.eng.blr.redhat.com:/gluster1/brick1/s1,rhshdp06.lab.eng.blr.redhat.com:/gluster1/brick1/s1

2. Run gdeploy: gdeploy -c gluster.conf

Actual results:

Backend setup succeeds, but add-brick fails

TASK: [Creates a Trusted Storage Pool] ****************************************
FATAL: no hosts matched or all hosts have already failed -- aborting


PLAY RECAP ********************************************************************
           to retry, use: --limit @/root/ansible_playbooks.retry

rhshdp03.lab.eng.blr.redhat.com : ok=0    changed=0    unreachable=0    failed=1
rhshdp04.lab.eng.blr.redhat.com : ok=0    changed=0    unreachable=0    failed=1
rhshdp05.lab.eng.blr.redhat.com : ok=11   changed=11   unreachable=0    failed=0
rhshdp06.lab.eng.blr.redhat.com : ok=11   changed=11   unreachable=0    failed=0
Comment 2 Anush Shetty 2015-09-15 10:17:15 EDT
A duplicate bug got created due to an issue with bugzilla.

Note You need to log in before you can comment on or make changes to this bug.