Bug 1263329 - [webadmin] Cannot edit cluster, dialog is not submitted [NPE @ GetClusterEditWarningsQuery]
[webadmin] Cannot edit cluster, dialog is not submitted [NPE @ GetClusterEdit...
Status: CLOSED DUPLICATE of bug 1263228
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity medium
: ---
: 3.6.0
Assigned To: Martin Betak
Pavel Novotny
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 10:41 EDT by Pavel Novotny
Modified: 2015-09-16 06:15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-16 06:15:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log - edit cluster - NPE (13.80 KB, text/plain)
2015-09-15 10:41 EDT, Pavel Novotny
no flags Details

  None (edit)
Description Pavel Novotny 2015-09-15 10:41:47 EDT
Created attachment 1073710 [details]
engine.log - edit cluster - NPE

Description of problem:
When trying to submit any changes to any existing cluster (including Default), the dialog does not react and NPE is thrown in engine.log.
This happens only in UI, updates via REST API work ok.

Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.15.master.el6.noarch
rhevm-webadmin-portal-3.6.0-0.15.master.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clean installation of RHEVM 3.6.
2. Log into webadmin, go to Clusters tab and create a cluster. Fill in whatever values you like.
3. Then edit the cluster and submit the dialog. It doesn't matter if you change any values there or not.


Actual results:
Dialog does not react to the OK button or Enter key and is still present. No error is shown in UI.
NullPointerException is thrown in engine.log, see attachment for full traceback.


Expected results:
Dialog is submited and all changes are applied.
No tracebacks in engine.log, of course.

Additional info:
Traceback snippet:

2015-09-15 13:09:37,454 ERROR [org.ovirt.engine.core.bll.GetClusterEditWarningsQuery] (ajp-/127.0.0.1:8702-7) [] Query 'GetClusterEditWarningsQuery' failed: null
2015-09-15 13:09:37,454 ERROR [org.ovirt.engine.core.bll.GetClusterEditWarningsQuery] (ajp-/127.0.0.1:8702-7) [] Exception: java.lang.NullPointerException
...
...
Comment 1 Martin Betak 2015-09-16 06:15:39 EDT

*** This bug has been marked as a duplicate of bug 1263228 ***

Note You need to log in before you can comment on or make changes to this bug.