Bug 1263366 - assertion failure in pyanaconda_tests/iutil_test.py
assertion failure in pyanaconda_tests/iutil_test.py
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 12:11 EDT by Alexander Todorov
Modified: 2016-02-09 05:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-09 05:55:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2015-09-15 12:11:00 EDT
Description of problem:

On the latest RHEL 7.2 nightly with the latest anaconda build I've extracted the tarball from the srpm and run `make check' inside. nosetests fail with this:


======================================================================
FAIL: Test the reset_handlers parameter of startProgram.
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/root/anaconda-21.48.22.46/tests/pyanaconda_tests/iutil_test.py", line 356, in start_program_reset_handlers_test
    self.assertEqual(proc.returncode, -(signal.SIGTERM))
AssertionError: -13 != -15


In addition I also see bug #1263363 which seems to be unrelated. At this point I'm not sure why this fails so please investigate.
Comment 3 RHEL Product and Program Management 2016-02-09 05:55:58 EST
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.