Bug 126337 - Printing problem, smbd panics
Printing problem, smbd panics
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: samba (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-19 04:47 EDT by Anton Rops
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:23:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anton Rops 2004-06-19 04:47:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
We made a fresh install of RHEL-3-U2. The setup of samba and cups are
standard. Two printers are installed via printtool with raw print queues.

It worked fine for about a week. Then one of the printers was not
accessible any more via samba. Restarting samba or rebooting did not
help. Once the problem was there it reproduces for 100%. If we print
directly from Linux it works fine. This is what we see in
/var/log/messages:

Jun 17 10:25:05 office smbd[19676]: [2004/06/17 10:25:05, 0]
lib/fault.c:fault_report(36)
Jun 17 10:25:05 office smbd[19676]:  
===============================================================

Jun 17 10:25:05 office smbd[19676]: [2004/06/17 10:25:05, 0]
lib/fault.c:fault_report(37)
Jun 17 10:25:05 office smbd[19676]:   INTERNAL ERROR: Signal 11 in pid
19676 (3.0.2-6.3E)
Jun 17 10:25:05 office smbd[19676]:   Please read the appendix Bugs of
the Samba HOWTO collection
Jun 17 10:25:05 office smbd[19676]: [2004/06/17 10:25:05, 0]
lib/fault.c:fault_report(39)
Jun 17 10:25:05 office smbd[19676]:  
===============================================================

Jun 17 10:25:05 office smbd[19676]: [2004/06/17 10:25:05, 0]
lib/util.c:smb_panic(1422)
Jun 17 10:25:05 office smbd[19676]:   PANIC: internal error
Jun 17 10:25:05 office smbd[19676]: [2004/06/17 10:25:05, 0]
lib/util.c:smb_panic(1430)
Jun 17 10:25:05 office smbd[19676]:   BACKTRACE: 15 stack frames:
Jun 17 10:25:05 office smbd[19676]:    #0 smbd(smb_panic+0x13f)
[0x801a608f]
Jun 17 10:25:05 office smbd[19676]:    #1 smbd [0x80191b48]
Jun 17 10:25:05 office smbd[19676]:    #2 /lib/tls/libc.so.6 [0xb7261de8]
Jun 17 10:25:05 office smbd[19676]:    #3
smbd(print_queue_status+0x186) [0x801c7246]
Jun 17 10:25:05 office smbd[19676]:    #4 smbd [0x8004eca3]
Jun 17 10:25:05 office smbd[19676]:    #5 smbd(api_reply+0x1cf)
[0x80055d4f]
Jun 17 10:25:05 office smbd[19676]:    #6 smbd [0x8004bdae]
Jun 17 10:25:05 office smbd[19676]:    #7 smbd(reply_trans+0x5ab)
[0x8004c53b]
Jun 17 10:25:05 office smbd[19676]:    #8 smbd [0x800901f0]
Jun 17 10:25:05 office smbd[19676]:    #9 smbd [0x80090403]
Jun 17 10:25:05 office smbd[19676]:    #10 smbd(process_smb+0xa6)
[0x80090656]
Jun 17 10:25:05 office smbd[19676]:    #11 smbd(smbd_process+0x192)
[0x800913d2]
Jun 17 10:25:05 office smbd[19676]:    #12 smbd(main+0x505) [0x8021d345]
Jun 17 10:25:05 office smbd[19676]:    #13
/lib/tls/libc.so.6(__libc_start_main+0xf8) [0xb724f768]
Jun 17 10:25:05 office smbd[19676]:    #14 smbd [0x80035a32]
Jun 17 10:25:05 office smbd[19676]:

For a moment we suspected the clients. But we moved back to our old RH
7.1 server (which we had phased out) and it works fine.

Version-Release number of selected component (if applicable):
samba-3.0.2-6.3E

How reproducible:
Always

Steps to Reproduce:
1. Once the problem exists: print from a W98 client
2.
3.
    

Actual Results:  No print, the samba service is interrupted. We lost
data because the file shares are interrupted.

Expected Results:  A printed page on the printer.

Additional info:

I checked bugzilla of samba.org. There is a fixed bug that seem to be
similar:

https://bugzilla.samba.org/show_bug.cgi?id=1147
Comment 1 Kit Gerrits 2004-07-21 13:42:08 EDT
The same problem has been signaled at:
https://www.redhat.com/OA_HTML/iburdt01.jsp?foo=bar&jtfm0=_0_0_-1_-
1_f_nv_&ibucr=bJShodK4&etfm1=&ibudf=DD-MON-
RRRR&kmcp=aJRendK4&jfn=ZG9F977CB90F702ED8EA4A9FA8A66F7E4B31EBA8DF33259
13AD8CC83829D7CDFC20C28B2107598524BA2EF1B878EA762E9E7&srID=336518
(not sure if this link works)

Redhat Service request number 336518

It includes smb.conf, kernel/samba version and smb.conf.
Comment 2 Marc Schmitt 2004-08-10 08:44:01 EDT
I'm seeing the same problem, running AS3, all errata applied
(2.4.21-15.0.4.EL, samba-3.0.4-6.3E). Printing worked for some time
then some of the jobs get stuck on the Windows XP client and stay
there forever. Some new jobs will come out of the printer but some
will not.
The log entries look like this (the log file gets pretty much flooded):

  ===============================================================
[2004/08/10 14:35:28, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 22708 (3.0.4-6.3E)
  Please read the appendix Bugs of the Samba HOWTO collection
[2004/08/10 14:35:28, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2004/08/10 14:35:28, 0] lib/util.c:smb_panic2(1407)
  PANIC: internal error
[2004/08/10 14:35:28, 0] lib/util.c:smb_panic2(1415)
  BACKTRACE: 22 stack frames:
   #0 smbd(smb_panic2+0x14f) [0x801b356f]
   #1 smbd(smb_panic+0x27) [0x801b3417]
   #2 smbd [0x8019e858]
   #3 /lib/tls/libc.so.6 [0xb7265de8]
   #4 smbd(_spoolss_rfnpcnex+0x19d) [0x800f9bfd]
   #5 smbd [0x800ed3f4]
   #6 smbd(api_rpcTNP+0x189) [0x80125de9]
   #7 smbd(api_pipe_request+0xc8) [0x80125b68]
   #8 smbd [0x8011e606]
   #9 smbd [0x8011e999]
   #10 smbd [0x8011ec19]
   #11 smbd [0x8011ee58]
   #12 smbd(write_to_pipe+0x115) [0x8011ed95]
   #13 smbd [0x8004cba1]
   #14 smbd(reply_trans+0x5ab) [0x8004d5db]
   #15 smbd [0x800960b8]
   #16 smbd [0x800962f3]
   #17 smbd(process_smb+0xa6) [0x80096546]
   #18 smbd(smbd_process+0x192) [0x80097362]
   #19 smbd(main+0x527) [0x8022e2c7]
   #20 /lib/tls/libc.so.6(__libc_start_main+0xf8) [0xb7253768]
   #21 smbd [0x80036722]
[2004/08/10 14:35:31, 1] smbd/ipc.c:api_fd_reply(292)
  api_fd_reply: INVALID PIPE HANDLE: 71a4
[2004/08/10 14:35:41, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2004/08/10 14:35:41, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 22709 (3.0.4-6.3E)
  Please read the appendix Bugs of the Samba HOWTO collection
[2004/08/10 14:35:41, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2004/08/10 14:35:41, 0] lib/util.c:smb_panic2(1407)
  PANIC: internal error
[2004/08/10 14:35:41, 0] lib/util.c:smb_panic2(1415)
  BACKTRACE: 22 stack frames:
   #0 smbd(smb_panic2+0x14f) [0x801b356f]
   #1 smbd(smb_panic+0x27) [0x801b3417]
   #2 smbd [0x8019e858]
   #3 /lib/tls/libc.so.6 [0xb7265de8]
etc etc.

Restarting samba does not help, rebooting the XP client has no effect,
either.

Has anyone succeded yet in fixing this?

Comment 3 Marc Schmitt 2004-08-10 12:10:41 EDT
I just noticed that the smbd does not stop properly anymore, either,
it has to be stopped twice for a clean shutdown of all smbd processes:

[root@vsgr1 samba]# ps -elf | grep smb
5 S root     25897     1  0  75   0    -  2839 schedu 18:06 ?       
00:00:00 smbd -D
1 S root     25901 25897  0  85   0    -  2839 pause  18:06 ?       
00:00:00 smbd -D
0 S root     25929  3702  0  81   0    -  1187 pipe_w 18:09 pts/2   
00:00:00 grep smb
[root@vsgr1 samba]# service smb stop
Shutting down SMB services:                                [  OK  ]
Shutting down NMB services:                                [  OK  ]
[root@vsgr1 samba]# ps -elf | grep smb
1 S root     25901     1  0  75   0    -  2839 pause  18:06 ?       
00:00:00 smbd -D
0 S root     25944  3702  0  76   0    -  1190 pipe_w 18:09 pts/2   
00:00:00 grep smb
[root@vsgr1 samba]# service smb stop
Shutting down SMB services:                                [  OK  ]
Shutting down NMB services:                                [FAILED]
[root@vsgr1 samba]# ps -elf | grep smb
0 S root     25965  3702  0  81   0    -  1191 pipe_w 18:09 pts/2   
00:00:00 grep smb
[root@vsgr1 samba]# service smb start
Starting SMB services:                                     [  OK  ]
Starting NMB services:                                     [  OK  ]
[root@vsgr1 samba]# ps -elf | grep smb
5 S root     25974     1  0  85   0    -  2834 schedu 18:09 ?       
00:00:00 smbd -D
1 S root     25975 25974  0  85   0    -  2834 pause  18:09 ?       
00:00:00 smbd -D
0 S root     25984  3702  0  75   0    -  1189 pipe_w 18:09 pts/2   
00:00:00 grep smb

But I guess this is just a side effect of the internal error panics.
Comment 4 Troels Walsted Hansen 2004-08-25 14:44:16 EDT
schmitt, your problem appears to be different from Anton's, the
backtraces are different.

I'm also experiencing schmitt's problem. It seems to be a bug in WinXP
SP2 triggering a bug in Samba. See
https://bugzilla.samba.org/show_bug.cgi?id=1520

I'm currently building a new Samba RPM with the patch from Samba
bugzilla. I'll post a link if it works...
Comment 5 Troels Walsted Hansen 2004-08-25 15:58:07 EDT
Well... The patch cured the crashing and allowed printing to work.
There is still a problem though, documents are never removed from the
print queue in Windows. The only way to make them disappear is to
delete them manually. I have updated the Smba bugzilla bug with this info.

You can grab the RPMs from the URL below if you like.
http://www.thule.no/~troels/code/samba-3.0.4-6.3Etwh1/
Comment 6 Kit Gerrits 2004-08-25 16:50:21 EDT
Another strange little thing:
Whenever Windows checks up on the printer, I get an overflow error in 
str_safecopy (32 bytes out of 31 allowed).

Aug 25 14:33:51 RedHat01 smbd[12222]: [2004/08/25 14:33:51, 0] 
lib/util_str.c:safe_strcpy_fn(600)
Aug 25 14:33:51 RedHat01 smbd[12222]:   ERROR: string overflow by 1 
(32 - 31) in safe_strcpy [\\redhat01\HP LaserJet 4000 Series PCL]

This occurred (I believe) after instaling the printer drivers for 
Windows (For plug-and-play printing).

I can print to most printers, except for one (no specific error, 
though)
Comment 7 Boris Mironov 2005-03-16 22:36:56 EST
Hello,

It seems that bug is still in the place. We hit this problem between WindowsXP 
SP1 and samba-3.0.10-1.fc3 What is interesting is that user cannot print PDF 
file on Xerox Phaser8400DP (PostScript driver), but at same time everything 
works fine for HP LaserJet 4100 PostScript diver.

Samba panics when prints 1st page of the document. But it is possible to print 
the rest of pages if select page range 2-...

Whole Samba server does not stop to be print server for other 30+ printers and 
even for this "poor" user.

Few words about our Samba:
- Fedora Core 3
- cups-1.1.22-0.rc1.8.5
- all printers are "raw"
- samba-3.0.10-1.fc3
- this server is member of ActiveDirectory environment

Here is session log:
[2005/03/16 12:17:23, 0] smbd/connection.c:register_message_flags(220)
  register_message_flags: tdb_fetch failed
[2005/03/16 12:18:13, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2005/03/16 12:18:13, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 13202 (3.0.10-1.fc3)
  Please read the appendix Bugs of the Samba HOWTO collection
[2005/03/16 12:18:13, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2005/03/16 12:18:13, 0] lib/util.c:smb_panic2(1504)
  PANIC: internal error
[2005/03/16 12:18:13, 0] lib/util.c:smb_panic2(1512)
  BACKTRACE: 20 stack frames:
   #0 smbd(smb_panic2+0x8a) [0x925efd]
   #1 smbd(smb_panic+0x19) [0x926129]
   #2 smbd [0x911669]
   #3 /lib/tls/libc.so.6 [0x3f0a48]
   #4 smbd(smb_io_notify_info_data_strings+0x1d6) [0x8c9aa4]
   #5 smbd [0x8c9e2d]
   #6 smbd(spoolss_io_r_rfnpcnex+0x8d) [0x8cd8e4]
   #7 smbd [0x862343]
   #8 smbd(api_rpcTNP+0x277) [0x8979ee]
   #9 smbd(api_pipe_request+0xa2) [0x897e42]
   #10 smbd [0x892c42]
   #11 smbd(write_to_pipe+0xee) [0x8918b3]
   #12 smbd [0x7bd603]
   #13 smbd(reply_trans+0x9d4) [0x7be1f7]
   #14 smbd [0x8098f2]
   #15 smbd(process_smb+0x195) [0x809d26]
   #16 smbd(smbd_process+0x15f) [0x80aa44]
   #17 smbd(main+0x865) [0x9a5ed7]
   #18 /lib/tls/libc.so.6(__libc_start_main+0xe3) [0x3dde33]
   #19 smbd [0x7a8231]
[2005/03/16 12:18:16, 0] smbd/connection.c:register_message_flags(220)
  register_message_flags: tdb_fetch failed

Hope this will help,
Please let me know if you need that PDF document.

Thanks,
Boris
Comment 8 RHEL Product and Program Management 2007-10-19 15:23:53 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.