Bug 12634 - ~/.dir_colors does not work (for me)
Summary: ~/.dir_colors does not work (for me)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fileutils   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
: 13465 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-19 18:20 UTC by giulioo
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-19 12:25:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description giulioo 2000-06-19 18:20:10 UTC
I copied /etc/DIR_COLORS into ~/.dir_colors, modified it, login, but it 
has no effect.
I could not find any place where .dir_colors is evaluated in the 
init/profile scripts.

I had to add 

if [ -f ~/.dir_colors ]; then
        eval `dircolors --sh ~/.dir_colors`
fi

into .bash_profile to make it work

Maybe the right thing would be to do it in /etc/profile.d/colorsls.sh

Comment 1 Bill Nottingham 2000-07-04 19:32:26 UTC
*** Bug 13465 has been marked as a duplicate of this bug. ***

Comment 2 Preston Brown 2000-07-10 19:40:38 UTC
fixed in rawhide.

Comment 3 Pekka Savola 2000-12-19 12:25:42 UTC
It seems /etc/DIR_COLORS talks about ~/.dir_colors, not ~/.dircolors which was implemented.

Please correct the other.


Comment 4 Bernhard Rosenkraenzer 2001-05-17 21:08:01 UTC
This was fixed in 4.1-2



Note You need to log in before you can comment on or make changes to this bug.