Bug 1263569 - Stage account 'stage_test_40_new' - no subscription pools list by subscription-manager CMD but can display pools by accessing to customer portal.
Stage account 'stage_test_40_new' - no subscription pools list by subscriptio...
Status: CLOSED NOTABUG
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.5
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Filip Nguyen
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 04:25 EDT by Liu Song
Modified: 2015-10-19 22:12 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-02 06:44:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liu Song 2015-09-16 04:25:30 EDT
Description of problem:
Stage account 'stage_test_40_new' - no subscription pools list using subscription CMD but can display pools by accessing to customer portal.

By CMD:
# subscription-manager register --username=stage_test_40_new --password=redhat
The system has been registered with ID: 394aa1e4-fb0b-4f89-aae6-80b0cb08ebcb 
# subscription-manager list --available --all
No available subscription pools to list

By accessing to customer portal:
Log in https://www.stage.redhat.com/wapps/sso/login.html with 'stage_test_40_new'.
Click 'CUSTMOR PORTAL' in the top of the page.
Click 'SUBSCRIPTIONS' in the page.
You can see 1400 active subscriptions in the stage account.

Because these subscriptions are active so they should be displayed by CMD, Who can help to check what happened here?
Comment 1 Filip Nguyen 2015-10-01 14:01:23 EDT
I cannot find this consumer in stage DB. Can you please share your /etc/rhsm/rhsm.conf and /var/log/rhsm/rhsm.log
Comment 2 Filip Nguyen 2015-10-01 14:01:39 EDT
see Comment 1
Comment 3 Filip Nguyen 2015-10-02 04:31:07 EDT
Canceling need info, I found to find the user in stage - probably my mistake
Comment 4 Filip Nguyen 2015-10-02 05:12:53 EDT
I can see the same behavior with this account. I will investigate further.
Comment 5 Filip Nguyen 2015-10-02 06:44:23 EDT
The subscriptions you are trying to use are only for RHUI consumer types. If you registered as standard SYSTEM these subscriptions will not be visible to that consumer.
Comment 6 Filip Nguyen 2015-10-02 08:16:18 EDT
just FYI, to set consumer type, use:

subscription-manager register --username=stage_test_40_new --password=redhat  --type=RHUI --force
Comment 7 Liu Song 2015-10-19 22:12:16 EDT
(In reply to Filip Nguyen from comment #6)
> just FYI, to set consumer type, use:
> 
> subscription-manager register --username=stage_test_40_new --password=redhat
> --type=RHUI --force

Hi Filip,

Thanks for your reminder, I set the type RHUI and get the correct result now:
# subscription-manager list --available --all|grep "SKU"
SKU:               RC0985946
SKU:               RC0295129
SKU:               RC0295129
SKU:               RC0985946
SKU:               RC0295129
SKU:               RC0985946
SKU:               RC0295129
SKU:               RC0985946
SKU:               RC0295129
SKU:               RC0985946
SKU:               RC0295129

Regards
Song

Note You need to log in before you can comment on or make changes to this bug.