Bug 1263589 - Can't detach a non master local data domain
Can't detach a non master local data domain
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Unspecified
unspecified Severity high
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Maor
Elad
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 05:06 EDT by Eyal Shenitzky
Modified: 2016-03-10 07:02 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine and vdsm logs (1014.09 KB, application/x-gzip)
2015-09-16 05:06 EDT, Eyal Shenitzky
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46216 master MERGED core: Support detach of local Storage Domain. Never
oVirt gerrit 46217 master NEW core: Refactor detach of local Storage Domain Never
oVirt gerrit 46295 ovirt-engine-3.6 MERGED core: Support detach of local Storage Domain Never
oVirt gerrit 46296 ovirt-engine-3.6 ABANDONED core: Refactor detach of local Storage Domain Never

  None (edit)
Description Eyal Shenitzky 2015-09-16 05:06:07 EDT
Created attachment 1073921 [details]
engine and vdsm  logs

Description of problem:
When trying to detach a non-master local data domain, the action is blocked on CanDoAction with the following reason:

2015-09-16 08:01:45,427 WARN  [org.ovirt.engine.core.bll.storage.RemoveStorageDomainCommand] (ajp-/127.0.0.1:8702-1) [] CanDoAction of action 'RemoveStorageDomain' failed for user admin@internal. Reasons: VAR__TYP
E__STORAGE__DOMAIN,VAR__ACTION__REMOVE,ACTION_TYPE_FAILED_FORMAT_STORAGE_DOMAIN_WITH_ATTACHED_DATA_DOMAIN


This operation shouldn't  be blocked with this reason since the domain is already attached to the data center 



Version-Release number of selected component (if applicable):
3.6.0-0.12.master.el6

How reproducible:
100%

Steps to Reproduce:
1.create local data center
2.create, attach and activate two data storage domains to the data center 
3.put the non master storage domain on maintenance
4.detach the domain 

Actual results:
operation is blocke with the mentioned CDA massage. On Webadmin:	
	
"
Operation Canceled
Error while executing action: Cannot remove Storage.
The Storage Domain metadata indicates it is already attached to a Data Center hence cannot be formatted.
To remove the Storage Domain one should either remove it without the format option or attach it to an existing Data Center, detach it, and try again
"

Expected results:
The reason for the operation to be blocked is wrong for the following:
1) The domain is attached to the local pool and not to another pool as described in the message
2) No possibility to remove without format as suggested in the message, without detaching it.

Additional info:
engine and vdsm logs
Comment 1 Allon Mureinik 2015-09-16 06:39:36 EDT
Looks like an easy win.
Greg, as this week's QA contact, please take look when you have a moment.
Comment 2 Maor 2015-09-16 07:21:49 EDT
Taking this since I already know the issue after I seat with Elad and Eyal
Comment 3 Elad 2015-10-14 11:25:12 EDT
A non master local data domain is now detachable. 

Verified using RHEV 3.6.0-15
rhevm-3.6.0-0.18.el6.noarch
vdsm-4.17.8-1.el7ev.noarch
Comment 4 Allon Mureinik 2016-03-10 05:40:20 EST
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE
Comment 5 Allon Mureinik 2016-03-10 05:40:26 EST
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE
Comment 6 Allon Mureinik 2016-03-10 05:45:55 EST
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE
Comment 7 Allon Mureinik 2016-03-10 07:02:31 EST
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.