Bug 126364 - libxslt has no requirement to python version it was rebuilded against
libxslt has no requirement to python version it was rebuilded against
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libxslt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-20 05:53 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-06 11:43:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-06-20 05:53:17 EDT
Description of problem:
libxslt has no requirement to python version it was rebuilded 
against.

Version-Release number of selected component (if applicable):
libxslt-1.1.7-2

Actual results / Expected results:
--- snipp ---
--- libxslt.spec       2004-04-19 00:49:33.000000000 +0200
+++ libxslt.spec.rsc   2004-06-20 11:50:41.000000000 +0200
@@ -38,7 +38,7 @@
 Requires: libxslt = %{version}
 Requires: libxml2 >= 2.6.8
 Requires: libxml2-python >= 2.6.8
-Requires: python
+Requires: %{_libdir}/python%(echo `python -c "import sys; print sys.version[0:3]"`)

 %description python
 The libxslt-python package contains a module that permits applications
--- snapp ---

Additional info:
libxml2 has this requirement already.
Comment 1 Robert Scheck 2004-07-06 11:20:38 EDT
Same issue also at libxslt-1.1.8-1...
Comment 2 Daniel Veillard 2004-07-06 11:43:54 EDT
Hum, right, I made the change upstream, this should show up in
a future release,

  sorry for the delay,

Daniel

Note You need to log in before you can comment on or make changes to this bug.