Bug 1263646 - No error message on fail of import storage domain
No error message on fail of import storage domain
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
All All
high Severity medium (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Amit Aviram
Lukas Svaty
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 06:52 EDT by Lukas Svaty
Modified: 2016-02-10 11:34 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 08:28:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.z?
rule-engine: planning_ack?
amureini: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 36451 None None None 2015-12-21 02:11 EST

  None (edit)
Description Lukas Svaty 2015-09-16 06:52:57 EDT
Created attachment 1073966 [details]
engine.log

Description of problem:
When trying to import storage domain of empty path no error message is displayed in webadmin portal

Version-Release number of selected component (if applicable):
rhevm-webadmin-portal-3.6.0-0.15.master.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create NFS storage
2. Create empty folder
3. In WA portal -> Storage -> Import Domain -> Path to nfs:/path/to/empty/folder

Actual results:
Nothing

Expected results:
Error message should be displayed to admin

Additional info:
engine.log
Comment 1 Sandro Bonazzola 2015-10-26 08:32:21 EDT
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high
Comment 3 Red Hat Bugzilla Rules Engine 2015-12-01 19:15:28 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 4 Red Hat Bugzilla Rules Engine 2015-12-01 19:15:28 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Amit Aviram 2015-12-20 09:37:26 EST
Lukas, you mean you are trying to import a storage domain from an empty folder on an nfs server?

When doing so, I get an error message saying:
"There is no storage domain under the specified path. Check event pane for more details."

So either I didn't understand the bug description or someone had fixed the bug already.
Comment 6 Allon Mureinik 2015-12-21 02:11:03 EST
IIUC, the fix Maor provided for bug 1138115 covers this scenario too. Moving to ON_QA for Lucas to verify.
Comment 7 Allon Mureinik 2015-12-21 02:13:23 EST
(In reply to Allon Mureinik from comment #6)
> IIUC, the fix Maor provided for bug 1138115 covers this scenario too. Moving
> to ON_QA for Lucas to verify.

To mistakes in this previous statement:
1. Lukas and not Lucas. My apologies for misspelling your name.
2. For some reason I assumed the qa contact for this BZ would be the same as the reporter. I won't presume to assign duties within the QE organization, of course.
Comment 8 Lukas Svaty 2015-12-21 03:02:19 EST
Hi,

1. Either Lucas/Lukas works :)
2. My mistake for not taking the bug on me in the first place.

VERIFIED in rhevm-webadmin-portal-3.6.1.3-0.1.el6.noarch

Current message:
There is no storage domain under the specified path. Check event pane for more details.
Comment 9 Sandro Bonazzola 2015-12-22 08:28:55 EST
oVirt 3.6.1 has been released and bz verified, moving to closed current release

Note You need to log in before you can comment on or make changes to this bug.