This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1263743 - Please backport fix for Intel Ironlake GPU crash caused by gstreamer1-vaapi
Please backport fix for Intel Ironlake GPU crash caused by gstreamer1-vaapi
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 10:56 EDT by Ting-Wei Lan
Modified: 2015-10-21 10:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 10:16:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1126956 None None None Never
Red Hat Bugzilla 1222324 None None None Never
FreeDesktop.org 91254 None None None Never

  None (edit)
Description Ting-Wei Lan 2015-09-16 10:56:51 EDT
Description of problem:
When gstreamer1-vaapi is installed, watching a video can cause the entire desktop to hang.

Version-Release number of selected component (if applicable):
mesa-10.6.3-3.20150729.fc22

How reproducible:
Always

Steps to Reproduce:
1. Use a computer with Intel Ironlake GPU
2. Select GNOME when logging in the system so gnome-shell is running
3. Watch a youtube video

Actual results:
No video and the desktop hangs. GNOME Shell crashes and it is possible to get gnome-session-failed. Messages found in dmesg:

[376521.038826] [drm] stuck on render ring
[376521.046064] [drm] GPU HANG: ecode 5:0:0x9ffdffff, in WebKitWebProces [20754], reason: Ring hung, action: reset
[376521.056196] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[376521.065517] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[376521.074489] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[376521.084225] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[376521.093269] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[376521.103937] drm/i915: Resetting chip after gpu hang
[376527.042154] [drm] stuck on render ring
[376527.048739] [drm] GPU HANG: ecode 5:0:0x9ffdffff, in WebKitWebProces [20754], reason: Ring hung, action: reset
[376527.059003] [drm:i915_set_reset_status [i915]] *ERROR* gpu hanging too fast, banning!
[376527.071083] drm/i915: Resetting chip after gpu hang

Expected results:
Video should play fine.

Additional info:
This bug is already reported and fixed upstream:
https://bugs.freedesktop.org/show_bug.cgi?id=91254
https://bugs.freedesktop.org/show_bug.cgi?id=91343

Patch is available here:
http://cgit.freedesktop.org/mesa/mesa/commit/?id=4e5752e2b78243a71766538f62ca0a80488047a7

After applying the patch, playing video no longer hangs the desktop, but I still see a green or blank screen instead of the video. It was reported for Fedora 20 in https://bugzilla.redhat.com/show_bug.cgi?id=1126956 and Fedora 22 in https://bugzilla.redhat.com/show_bug.cgi?id=1222324. I still think it is nice to include the patch because web browser segfault is better than entire desktop crash.
Comment 1 Ting-Wei Lan 2015-10-21 10:16:30 EDT
mesa-10.6.9-1.20151008.fc22 is available in updates.

Note You need to log in before you can comment on or make changes to this bug.