Bug 126378 - incorrect file context for j2sdk files
incorrect file context for j2sdk files
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-strict (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-20 16:32 EDT by Tom London
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-24 12:13:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2004-06-20 16:32:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
If you install j2sdk (instead of j2re), the mozilla plugin library
is incorrectly labelled as lib_t (should be shlib_t)

Perhaps, change /etc/selinux/strict/src/policy/file_contexts/type.fc:

/usr/java/j2re1.*/plugin/i386(/.*)?/lib[^/]*\.so(\.[^/]*)* --
system_u:object_r:shlib_t

to

/usr/java/j2.*/plugin/i386(/.*)?/lib[^/]*\.so(\.[^/]*)* --
system_u:object_r:shlib_t

[The problem is that j2sdk put the plugin library in a slightly
different place ...]

Version-Release number of selected component (if applicable):
selinux-policy-strict-1.13.7-1 

How reproducible:
Always

Steps to Reproduce:
1. install j2sdk
2. run fixfiles ..., restorecon, ...
3.
    

Additional info:
Comment 1 Daniel Walsh 2004-06-23 17:44:06 EDT
Fixed in selinux-policy-strict-1.13.8-1
Comment 2 Tom London 2004-06-24 12:13:35 EDT
Fixed.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.