Bug 126382 - [PATCH] Sparc patch
Summary: [PATCH] Sparc patch
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-20 21:15 UTC by Dan Williams
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 11:28:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix sparc breakage (1.21 KB, text/plain)
2004-06-20 21:16 UTC, Dan Williams
no flags Details

Description Dan Williams 2004-06-20 21:15:38 UTC
For various reasons, vnc's internal copy of X.org doesn't build on sparc.  Patch attached.

Comment 1 Dan Williams 2004-06-20 21:16:42 UTC
Created attachment 101279 [details]
fix sparc breakage

Comment 2 Tim Waugh 2004-06-24 13:35:00 UTC
Applied in 4.0-3.  Doesn't xorg-x11 need the patch as well?

Comment 3 Dan Williams 2004-06-24 13:46:17 UTC
yes, most likely it does...

Comment 4 Mike A. Harris 2004-06-25 23:50:55 UTC
Please file a bug report upstream with patch attached, and once the
patch is merged into upstream X.Org CVS, we will consider including
it in our X.Org rpms as well.

http://www.freedesktop.org  xorg component

Include upstream bug URL here once filed upstream for tracking.

TIA

Comment 5 Mike A. Harris 2004-07-05 21:25:50 UTC
Closing "WONTFIX" as sparc is an unsupported platform, however you can
submit sparc related fixes to upstream X.Org at the URL in comment #4
above, and the changes will get included into future X.Org releases,
and will make it into rawhide for FC3.



Comment 6 Dan Williams 2004-07-05 23:44:32 UTC
Mike:

http://freedesktop.org/bugzilla/show_bug.cgi?id=825

Comment 7 Mike A. Harris 2004-07-06 01:41:38 UTC
Thanks for the URL Dan..

updating status to UPSTREAM for tracking.

Comment 8 Mike A. Harris 2004-09-01 11:28:33 UTC
The upstream bug report seems to have been ignored so far, and
the patch seems like it might cause problems on older Linux kernels
which X.Org may wish to support still.  It's not confirmed, but
just a personal observation.  I recommend discussing this patch
on the xorg mailing list with other developers, and working with
the community of developers to come up with a solution which is
considered safe to commit to CVS.  Since we don't support sparc
architecture however, I don't see any reason to continue monitoring
this issue in the upstream bugzilla.  Once the issue is fixed in
upstream CVS, and we're using Xorg sources based upon that, our
rpms will eventually have the fixes included as well.

Closing as "WONTFIX"


Note You need to log in before you can comment on or make changes to this bug.