Bug 1263944 - FileNotFoundError: [Errno 2] No such file or directory: 'systemctl'
FileNotFoundError: [Errno 2] No such file or directory: 'systemctl'
Status: CLOSED DUPLICATE of bug 1262953
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:d2bd0b532bb3590ef5316fa7248...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 02:59 EDT by A.J. Werkman
Modified: 2015-09-17 03:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-17 03:42:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (941.17 KB, text/plain)
2015-09-17 02:59 EDT, A.J. Werkman
no flags Details
File: anaconda.log (47.86 KB, text/plain)
2015-09-17 02:59 EDT, A.J. Werkman
no flags Details
File: dnf.log (18.20 KB, text/plain)
2015-09-17 02:59 EDT, A.J. Werkman
no flags Details
File: dnf.rpm.log (261.37 KB, text/plain)
2015-09-17 02:59 EDT, A.J. Werkman
no flags Details
File: environ (459 bytes, text/plain)
2015-09-17 02:59 EDT, A.J. Werkman
no flags Details
File: lsblk_output (2.87 KB, text/plain)
2015-09-17 02:59 EDT, A.J. Werkman
no flags Details
File: nmcli_dev_list (1.13 KB, text/plain)
2015-09-17 02:59 EDT, A.J. Werkman
no flags Details
File: os_info (451 bytes, text/plain)
2015-09-17 02:59 EDT, A.J. Werkman
no flags Details
File: program.log (146.32 KB, text/plain)
2015-09-17 02:59 EDT, A.J. Werkman
no flags Details
File: storage.log (191.75 KB, text/plain)
2015-09-17 02:59 EDT, A.J. Werkman
no flags Details
File: syslog (95.18 KB, text/plain)
2015-09-17 02:59 EDT, A.J. Werkman
no flags Details
File: ifcfg.log (2.31 KB, text/plain)
2015-09-17 02:59 EDT, A.J. Werkman
no flags Details
File: packaging.log (3.66 KB, text/plain)
2015-09-17 03:00 EDT, A.J. Werkman
no flags Details

  None (edit)
Description A.J. Werkman 2015-09-17 02:59:35 EDT
Description of problem:
Standars Server installation using ISO-image 23_Beta_RC1

Version-Release number of selected component:
anaconda-23.19.4-1

The following was filed automatically by anaconda:
anaconda 23.19.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/subprocess.py", line 1457, in _execute_child
    raise child_exception_type(errno_num, err_msg)
  File "/usr/lib64/python3.4/subprocess.py", line 859, in __init__
    restore_signals, start_new_session)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 201, in startProgram
    preexec_fn=preexec, cwd=root, env=env, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 279, in _run_program
    env_prune=env_prune)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 358, in execWithRedirect
    log_output=log_output, binary_output=binary_output)[0]
  File "/usr/lib64/python3.4/site-packages/pyanaconda/iutil.py", line 336, in execInSysroot
    return execWithRedirect(command, argv, stdin=stdin, root=getSysroot())
  File "/usr/lib64/python3.4/site-packages/pyanaconda/kickstart.py", line 1653, in execute
    iutil.execInSysroot("systemctl", ["enable", svc])
  File "/usr/lib64/python3.4/site-packages/pyanaconda/install.py", line 79, in doConfiguration
    ksdata.services.execute(storage, ksdata, instClass)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
FileNotFoundError: [Errno 2] No such file or directory: 'systemctl'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz noselinux ip=172.18.92.70::172.18.92.65:255.255.255.192:cfl.lc.digifarma.nl::off noipv6 nameserver=172.18.92.65 inst.stage2=hd:UUID=c98f6f60-f5fe-4bf9-b500-8e918649636a inst.repo=http://dl.fedoraproject.org/pub/alt/stage/23_Beta_RC1/Server/x86_64/os
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23
Comment 1 A.J. Werkman 2015-09-17 02:59:41 EDT
Created attachment 1074293 [details]
File: anaconda-tb
Comment 2 A.J. Werkman 2015-09-17 02:59:43 EDT
Created attachment 1074294 [details]
File: anaconda.log
Comment 3 A.J. Werkman 2015-09-17 02:59:44 EDT
Created attachment 1074295 [details]
File: dnf.log
Comment 4 A.J. Werkman 2015-09-17 02:59:47 EDT
Created attachment 1074296 [details]
File: dnf.rpm.log
Comment 5 A.J. Werkman 2015-09-17 02:59:48 EDT
Created attachment 1074297 [details]
File: environ
Comment 6 A.J. Werkman 2015-09-17 02:59:49 EDT
Created attachment 1074298 [details]
File: lsblk_output
Comment 7 A.J. Werkman 2015-09-17 02:59:50 EDT
Created attachment 1074299 [details]
File: nmcli_dev_list
Comment 8 A.J. Werkman 2015-09-17 02:59:51 EDT
Created attachment 1074300 [details]
File: os_info
Comment 9 A.J. Werkman 2015-09-17 02:59:53 EDT
Created attachment 1074301 [details]
File: program.log
Comment 10 A.J. Werkman 2015-09-17 02:59:56 EDT
Created attachment 1074302 [details]
File: storage.log
Comment 11 A.J. Werkman 2015-09-17 02:59:58 EDT
Created attachment 1074303 [details]
File: syslog
Comment 12 A.J. Werkman 2015-09-17 02:59:59 EDT
Created attachment 1074304 [details]
File: ifcfg.log
Comment 13 A.J. Werkman 2015-09-17 03:00:00 EDT
Created attachment 1074305 [details]
File: packaging.log
Comment 14 Vojtech Trefny 2015-09-17 03:42:44 EDT

*** This bug has been marked as a duplicate of bug 1262953 ***

Note You need to log in before you can comment on or make changes to this bug.