Bug 1263952 - After reset the cartridges : jbosseap-6\postgresql-9.2\postgresql-8.4 were absent on INT env.
After reset the cartridges : jbosseap-6\postgresql-9.2\postgresql-8.4 were ab...
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: John W. Lamb
DeShuai Ma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 03:39 EDT by zhou ying
Modified: 2017-05-31 14:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-31 14:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhou ying 2015-09-17 03:39:18 EDT
Description of problem:
After reset ,the cartridges : jbosseap-6\postgresql-9.2\postgresql-8.4 were absent on INT env.

Version-Release number of selected component (if applicable):
INT

How reproducible:
always

Steps to Reproduce:
1. Login the reset INT env;
2. List all the cartridges on INT:
  `rhc cartridge list`

Actual results:
[zhouy@zhouy bugs]$ rhc server-show  int.openshift.redhat.com
Server 'int' (in use)
---------------------
  Hostname:        int.openshift.redhat.com
  Login:           libra-test+power28@redhat.com
  Use Auth Tokens: true
  Insecure:        true
[zhouy@zhouy premigrate]$ rhc cartridge list
jbossas-7                JBoss Application Server 7             web
jboss-dv-6.1.0 (!)       JBoss Data Virtualization 6            web
jboss-unified-push-2 (!) JBoss Unified Push Server 1.0.0.Beta2  web
jenkins-1                Jenkins Server                         web
nodejs-0.10              Node.js 0.10                           web
perl-5.10                Perl 5.10                              web
php-5.3                  PHP 5.3                                web
php-5.4                  PHP 5.4                                web
zend-6.1                 PHP 5.4 with Zend Server 6.1           web
python-2.6               Python 2.6                             web
python-2.7               Python 2.7                             web
python-3.3               Python 3.3                             web
ruby-1.8                 Ruby 1.8                               web
ruby-1.9                 Ruby 1.9                               web
ruby-2.0                 Ruby 2.0                               web
jbossews-1.0             Tomcat 6 (JBoss EWS 1.0)               web
jbossews-2.0             Tomcat 7 (JBoss EWS 2.0)               web
jboss-vertx-2.1 (!)      Vert.x 2.1                             web
jboss-wildfly-8 (!)      WildFly Application Server 8.2.1.Final web
jboss-wildfly-9 (!)      WildFly Application Server 9           web
diy-0.1                  Do-It-Yourself 0.1                     web
cron-1.4                 Cron 1.4                               addon
jenkins-client-1         Jenkins Client                         addon
mongodb-2.4              MongoDB 2.4                            addon
mysql-5.1                MySQL 5.1                              addon
mysql-5.5                MySQL 5.5                              addon
phpmyadmin-4             phpMyAdmin 4.0                         addon
rockmongo-1.1            RockMongo 1.1                          addon
switchyard-0             SwitchYard 0.8.0                       addon
haproxy-1.4              Web Load Balancer                      addon


Expected results:
Should contain the cartridges in lists:jbosseap-6\postgresql-9.2\postgresql-8.4 

Additional info:
Comment 1 Stefanie Forrester 2015-10-19 18:51:29 EDT
This seems to be resolved with the latest release.

[dakini@nibbana ~]$ rhc server-show int.openshift.redhat.com
Server 'int' (in use)
---------------------
  Hostname:    int.openshift.redhat.com
  Login:       sedgar+2@redhat.com
  SSL Version: TLSv1
[dakini@nibbana ~]$ rhc cartridge list |grep -e jbosseap-6 -e postgresql-9.2 -e postgresql-8.4                                
jbosseap-6 (*)           JBoss Enterprise Application Platform 6 web
postgresql-8.4           PostgreSQL 8.4                          addon
postgresql-9.2           PostgreSQL 9.2                          addon
Comment 2 zhou ying 2015-10-20 02:30:09 EDT
Confirm on INT :
[zhouy@zhouy Work]$ rhc cartridge-list
jbossas-7                JBoss Application Server 7              web
jboss-dv-6.1.0 (!)       JBoss Data Virtualization 6             web
jboss-dv-6.0.0 (!)       JBoss Data Virtualization 6             web
jbosseap-6 (*)           JBoss Enterprise Application Platform 6 web
jboss-unified-push-2 (!) JBoss Unified Push Server 1.0.0.Beta2   web
jenkins-1                Jenkins Server                          web
nodejs-0.10              Node.js 0.10                            web
perl-5.10                Perl 5.10                               web
php-5.3                  PHP 5.3                                 web
php-5.4                  PHP 5.4                                 web
zend-6.1                 PHP 5.4 with Zend Server 6.1            web
python-2.6               Python 2.6                              web
python-2.7               Python 2.7                              web
python-3.3               Python 3.3                              web
ruby-1.8                 Ruby 1.8                                web
ruby-1.9                 Ruby 1.9                                web
ruby-2.0                 Ruby 2.0                                web
jbossews-1.0             Tomcat 6 (JBoss EWS 1.0)                web
jbossews-2.0             Tomcat 7 (JBoss EWS 2.0)                web
jboss-vertx-2.1 (!)      Vert.x 2.1                              web
jboss-wildfly-8 (!)      WildFly Application Server 8.2.1.Final  web
jboss-wildfly-9 (!)      WildFly Application Server 9            web
diy-0.1                  Do-It-Yourself 0.1                      web
cron-1.4                 Cron 1.4                                addon
jenkins-client-1         Jenkins Client                          addon
mongodb-2.4              MongoDB 2.4                             addon
mysql-5.1                MySQL 5.1                               addon
mysql-5.5                MySQL 5.5                               addon
phpmyadmin-4             phpMyAdmin 4.0                          addon
postgresql-8.4           PostgreSQL 8.4                          addon
postgresql-9.2           PostgreSQL 9.2                          addon
rockmongo-1.1            RockMongo 1.1                           addon
switchyard-0             SwitchYard 0.8.0                        addon
haproxy-1.4              Web Load Balancer                       addon

Note: Web cartridges can only be added to new applications.

(*) denotes a cartridge with additional usage costs.

(!) denotes a cartridge that will not receive automatic security updates.

[zhouy@zhouy Work]$ rhc server-show int.openshift.redhat.com
Server 'int' (in use)
---------------------
  Hostname:        int.openshift.redhat.com
  Login:           yinzhou@redhat.com
  Use Auth Tokens: true
  Insecure:        true

Use 'rhc servers' to display all your servers.
Comment 3 Eric Paris 2017-05-31 14:22:11 EDT
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.

Note You need to log in before you can comment on or make changes to this bug.