Bug 126398 - xmodmap seems to lay ESCAPE on 0
xmodmap seems to lay ESCAPE on 0
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 126397 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-21 04:40 EDT by Thorsten Stärk
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-13 05:36:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xmodmap to reproduce the problem (6.24 KB, text/plain)
2004-06-21 05:23 EDT, Thorsten Stärk
no flags Details

  None (edit)
Description Thorsten Stärk 2004-06-21 04:40:23 EDT
Description of problem:
I go into a konsole, load this xmodmap and type the key 0 and 1 on the
keypad. I want to see 01 in the konsole, but I see  
(arg: 1) 0

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1.xmodmap .Xmodmap.de-dvorak
2.start konsole
3.type fast 01 on the keypad
  
Actual results:


Expected results:


Additional info:
Comment 1 Thorsten Stärk 2004-06-21 05:22:19 EDT
*** Bug 126397 has been marked as a duplicate of this bug. ***
Comment 2 Thorsten Stärk 2004-06-21 05:23:19 EDT
Created attachment 101289 [details]
xmodmap to reproduce the problem
Comment 4 Kristian Høgsberg 2004-07-08 13:21:32 EDT
What does xev report when you type keypad-0?  Also, do you get correct
behaviour when you don't load the xmodmap file?
Comment 5 Thorsten Stärk 2004-07-09 05:12:46 EDT
[tstaerk@ls3523 tstaerk]$ xev
Outer window is 0x3600001, inner window is 0x3600002

PropertyNotify event, serial 8, synthetic NO, window 0x3600001,
    atom 0x27 (WM_NAME), time 5865027, state PropertyNewValue

PropertyNotify event, serial 9, synthetic NO, window 0x3600001,
    atom 0x22 (WM_COMMAND), time 5865027, state PropertyNewValue

PropertyNotify event, serial 10, synthetic NO, window 0x3600001,
    atom 0x28 (WM_NORMAL_HINTS), time 5865027, state PropertyNewValue

CreateNotify event, serial 11, synthetic NO, window 0x3600001,
    parent 0x3600001, window 0x3600002, (10,10), width 50, height 50
border_width 4, override NO

MapNotify event, serial 12, synthetic NO, window 0x3600001,
    event 0x3600001, window 0x3600002, override NO

PropertyNotify event, serial 13, synthetic NO, window 0x3600001,
    atom 0x169 (_KDE_NET_WM_USER_CREATION_TIME), time 5865027, state
PropertyNewValue

ConfigureNotify event, serial 13, synthetic NO, window 0x3600001,
    event 0x3600001, window 0x3600001, (0,0), width 178, height 178,
    border_width 0, above 0x3400598, override NO

ReparentNotify event, serial 13, synthetic NO, window 0x3600001,
    event 0x3600001, window 0x3600001, parent 0xe0786b,
    (0,0), override NO

PropertyNotify event, serial 13, synthetic NO, window 0x3600001,
    atom 0xef (_NET_WM_DESKTOP), time 5865030, state PropertyNewValue

PropertyNotify event, serial 13, synthetic NO, window 0x3600001,
    atom 0x108 (_KDE_NET_WM_FRAME_STRUT), time 5865031, state
PropertyNewValue

PropertyNotify event, serial 13, synthetic NO, window 0x3600001,
    atom 0x145 (_NET_WM_ALLOWED_ACTIONS), time 5865031, state
PropertyNewValue

PropertyNotify event, serial 13, synthetic NO, window 0x3600001,
    atom 0x70 (WM_STATE), time 5865031, state PropertyNewValue

ConfigureNotify event, serial 13, synthetic YES, window 0x3600001,
    event 0x3600001, window 0x3600001, (4,21), width 178, height 178,
    border_width 0, above 0x0, override NO

MapNotify event, serial 13, synthetic NO, window 0x3600001,
    event 0x3600001, window 0x3600001, override NO

VisibilityNotify event, serial 13, synthetic NO, window 0x3600001,
    state VisibilityFullyObscured

FocusIn event, serial 13, synthetic NO, window 0x3600001,
    mode NotifyNormal, detail NotifyNonlinear

KeymapNotify event, serial 13, synthetic NO, window 0x0,
    keys:  0   0   0   0   16  0   0   0   0   0   0   0   0   0   0   0
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

VisibilityNotify event, serial 13, synthetic NO, window 0x3600001,
    state VisibilityUnobscured

Expose event, serial 13, synthetic NO, window 0x3600001,
    (0,0), width 178, height 10, count 3

Expose event, serial 13, synthetic NO, window 0x3600001,
    (0,10), width 10, height 58, count 2

Expose event, serial 13, synthetic NO, window 0x3600001,
    (68,10), width 110, height 58, count 1

Expose event, serial 13, synthetic NO, window 0x3600001,
    (0,68), width 178, height 110, count 0

PropertyNotify event, serial 13, synthetic NO, window 0x3600001,
    atom 0xee (_NET_WM_STATE), time 5865041, state PropertyNewValue

KeyRelease event, serial 22, synthetic NO, window 0x3600001,
    root 0x71, subw 0x0, time 5865143, (563,206), root:(567,227),
    state 0x10, keycode 36 (keysym 0xff0d, Return), same_screen YES,
"   XLookupString gives 1 bytes:  "

PropertyNotify event, serial 25, synthetic NO, window 0x3600001,
    atom 0x142 (_NET_WM_ICON_GEOMETRY), time 5865151, state
PropertyNewValue

PropertyNotify event, serial 25, synthetic NO, window 0x3600001,
    atom 0x142 (_NET_WM_ICON_GEOMETRY), time 5865152, state
PropertyNewValue

KeyPress event, serial 26, synthetic NO, window 0x3600001,
    root 0x71, subw 0x0, time 5871126, (563,205), root:(567,226),
    state 0x10, keycode 19 (keysym 0x30, 0), same_screen YES,
    XLookupString gives 1 bytes:  "0"

KeyRelease event, serial 26, synthetic NO, window 0x3600001,
    root 0x71, subw 0x0, time 5871204, (563,205), root:(567,226),
    state 0x18, keycode 19 (keysym 0x30, 0), same_screen YES,
    XLookupString gives 1 bytes:  "0"

FocusOut event, serial 26, synthetic NO, window 0x3600001,
    mode NotifyNormal, detail NotifyNonlinear

PropertyNotify event, serial 26, synthetic NO, window 0x3600001,
    atom 0x142 (_NET_WM_ICON_GEOMETRY), time 5873981, state
PropertyNewValue

Comment 6 Uwe Menges 2004-07-12 04:24:02 EDT
I also use this Xmodmap and experience this error. This are the two
cases (with standard 0):

1. Slow keypress (no error)

  KeyPress event, serial 27, synthetic NO, window 0x2800001,
    root 0x48, subw 0x0, time 345531370, (880,-15), root:(884,777),
    state 0x0, keycode 19 (keysym 0x30, 0), same_screen YES,
    XLookupString gives 1 bytes: (30) "0"
    XmbLookupString gives 1 bytes: (30) "0"
    XFilterEvent returns: False

  KeyRelease event, serial 30, synthetic NO, window 0x2800001,
    root 0x48, subw 0x0, time 345531485, (880,-15), root:(884,777),
    state 0x8, keycode 19 (keysym 0x30, 0), same_screen YES,
    XLookupString gives 1 bytes: (30) "0"

  KeyPress event, serial 30, synthetic NO, window 0x2800001,
    root 0x48, subw 0x0, time 345533687, (880,-15), root:(884,777),
    state 0x0, keycode 10 (keysym 0x31, 1), same_screen YES,
    XLookupString gives 1 bytes: (31) "1"
    XmbLookupString gives 1 bytes: (31) "1"
    XFilterEvent returns: False

  KeyRelease event, serial 30, synthetic NO, window 0x2800001,
    root 0x48, subw 0x0, time 345533802, (880,-15), root:(884,777),
    state 0x0, keycode 10 (keysym 0x31, 1), same_screen YES,
    XLookupString gives 1 bytes: (31) "1"

2. Fast keypress (error case)

  KeyPress event, serial 30, synthetic NO, window 0x2800001,
    root 0x48, subw 0x0, time 345536996, (880,-15), root:(884,777),
    state 0x0, keycode 19 (keysym 0x30, 0), same_screen YES,
    XLookupString gives 1 bytes: (30) "0"
    XmbLookupString gives 1 bytes: (30) "0"
    XFilterEvent returns: False

  KeyPress event, serial 30, synthetic NO, window 0x2800001,
    root 0x48, subw 0x0, time 345537000, (880,-15), root:(884,777),
    state 0x8, keycode 10 (keysym 0x31, 1), same_screen YES,
    XLookupString gives 1 bytes: (31) "1"
    XmbLookupString gives 1 bytes: (31) "1"
    XFilterEvent returns: False

  KeyRelease event, serial 30, synthetic NO, window 0x2800001,
    root 0x48, subw 0x0, time 345537076, (880,-15), root:(884,777),
    state 0x8, keycode 19 (keysym 0x30, 0), same_screen YES,
    XLookupString gives 1 bytes: (30) "0"

  KeyRelease event, serial 30, synthetic NO, window 0x2800001,
    root 0x48, subw 0x0, time 345537115, (880,-15), root:(884,777),
    state 0x0, keycode 10 (keysym 0x31, 1), same_screen YES,
    XLookupString gives 1 bytes: (31) "1"

I looked at xev output after doing a 'setxkbmap de' (where the error
doesn't occur) and found it says "state 0x0" at the '0' KeyRelease
event, instead of 0x8.

Here the keypad-0:
 
  KeyPress event, serial 30, synthetic NO, window 0x2200001,
    root 0x48, subw 0x0, time 347650616, (888,-276), root:(892,516),
    state 0x10, keycode 90 (keysym 0xffb0, KP_0), same_screen YES,
    XLookupString gives 1 bytes: (30) "0"
    XmbLookupString gives 1 bytes: (30) "0"
    XFilterEvent returns: False

  KeyRelease event, serial 30, synthetic NO, window 0x2200001,
    root 0x48, subw 0x0, time 347650767, (888,-276), root:(892,516),
    state 0x10, keycode 90 (keysym 0xffb0, KP_0), same_screen YES,
    XLookupString gives 1 bytes: (30) "0"

I assume the state is +0x10 because I turned NumLock on.

It seems reasonable that the state 0x8 at KeyRelease may be a hint, as
it only occurs in the error case and only at the strange behaving key (0).
Comment 7 Kristian Høgsberg 2004-07-12 12:31:50 EDT
It looks like your 0 (not keypad 0) is set up to work as Alt.  State
0x8 is Mod1 (Alt) and if you press Alt-1 you see the same behaviour.

The problem is this line:

  add    Mod1    = Alt_L 0x007D 0x009C

which adds 0x007D to the Mod1 modifier map. 0x007D is braceright which
is on the 0-key.  Try to remove 0x007D and 0x009C.
Comment 8 Thorsten Stärk 2004-07-13 05:36:42 EDT
thanks a lot, works for both of us.
XKeyCaps did not behave as we expected.

Note You need to log in before you can comment on or make changes to this bug.