Bug 1263983 - systemd[1]: [/usr/lib/systemd/system/momd.service:11] Unknown lvalue 'Timeout' in section 'Service'
systemd[1]: [/usr/lib/systemd/system/momd.service:11] Unknown lvalue 'Timeout...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mom (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity low
: ovirt-3.6.6
: 3.6.6
Assigned To: Andrej Krejcir
Shira Maximov
: Reopened, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 05:12 EDT by Fabian Deutsch
Modified: 2016-06-13 06:38 EDT (History)
15 users (show)

See Also:
Fixed In Version: mom-0.5.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-13 06:38:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53468 master MERGED Fix momd.service file syntax 2016-02-15 04:43 EST

  None (edit)
Description Fabian Deutsch 2015-09-17 05:12:03 EDT
Description of problem:
mom can not be started on RHEV-H 3.6.0:
[   21.275662] localhost systemd[1]: [/usr/lib/systemd/system/momd.service:11] Unknown lvalue 'Timeout' in section 'Service'

Version-Release number of selected component (if applicable):
RHEV-H 3.6 build

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Fabian Deutsch 2015-09-17 05:12:52 EDT
Maybe TimeoutSec should be used for the lvalue?
Comment 2 Adam Litke 2015-09-17 09:06:07 EDT
Martin, can you take point on this one please?
Comment 3 Martin Sivák 2015-09-17 11:07:21 EDT
I will take care of that, but have this ever worked on any other systemd based system? Because I just saw a system where this was fine.
Comment 4 Martin Sivák 2015-09-17 11:10:07 EDT
Ah... you are using a wrong service. It should be vdsm-mom.service as momd.service is the standalone mode.
Comment 5 Yaniv Kaul 2016-01-26 07:09:54 EST
Re-opening, just saw it on my lago setup:
Jan 26 05:49:19 lago_basic_suite_3_6_host0 systemd: [/usr/lib/systemd/system/momd.service:11] Unknown lvalue 'Timeout' in section 'Service'

[root@lago_basic_suite_3_6_host0 ~]# rpm -qa |grep mom
mom-0.5.1-2.el7.noarch

[root@lago_basic_suite_3_6_host0 ~]# cat /usr/lib/systemd/system/momd.service
[Unit]
Description=Memory Overcommitment Manager Daemon
After=libvirtd.service

[Service]
Type=forking
PIDFile=/var/run/momd.pid
User=root
Group=root
ExecStart=/usr/sbin/momd -c /etc/momd.conf -d --pid-file /var/run/momd.pid
Timeout=60
Restart=on-abort


[root@lago_basic_suite_3_6_host0 ~]# rpm -qa |grep vdsm
vdsm-python-4.17.18-0.el7.centos.noarch
vdsm-yajsonrpc-4.17.18-0.el7.centos.noarch
vdsm-4.17.18-0.el7.centos.noarch
vdsm-infra-4.17.18-0.el7.centos.noarch
vdsm-hook-vmfex-dev-4.17.18-0.el7.centos.noarch
vdsm-xmlrpc-4.17.18-0.el7.centos.noarch
vdsm-jsonrpc-4.17.18-0.el7.centos.noarch
vdsm-cli-4.17.18-0.el7.centos.noarch
Comment 7 Doron Fediuck 2016-01-26 08:34:49 EST
Yaniv, which mom version are you using?
Comment 8 Martin Sivák 2016-01-26 09:17:36 EST
Yaniv, you are using a wrong service. Please disable mom.service and use mom-vdsm.service.
Comment 9 Fabian Deutsch 2016-01-26 09:25:29 EST
If mom.service is wrong, why is it enabled?
Comment 10 Martin Sivák 2016-01-26 09:59:23 EST
No idea really, vdsm uses mom-vdsm and that one conflicts with plain momd.
Comment 11 Yaniv Kaul 2016-01-26 10:08:30 EST
(In reply to Martin Sivák from comment #8)
> Yaniv, you are using a wrong service. Please disable mom.service and use
> mom-vdsm.service.

This is what I've got when using Lago. I believe Lago hosts have 7.1 installed - I certainly did not install anything manually.
If the base image has something wrong, we need to fix it - but I'd certainly expect VDSM installation to disable or warn or something on whatever is bothering it.
Comment 12 Roy Golan 2016-02-10 05:32:08 EST
This is not related to ovirt specifically as we have mom-vdsm.service and we should hit that unless you started intentionally momd.service (this is used by some upstream users, not using ovirt)

Martin/Andrej just needs to make sure the syntax of momd.service file is valid in this systemd version.
Comment 13 Sandro Bonazzola 2016-04-27 09:41:13 EDT
Martin I don't see any mom build in 3.6.6, can you check the status of this bug?
Comment 14 Martin Sivák 2016-04-27 10:30:54 EDT
Take the one from 3.6.5...
Comment 15 Yaniv Lavi (Dary) 2016-05-05 08:28:38 EDT
Should this be on qa?
Comment 16 Gil Klein 2016-05-05 11:10:42 EDT
Moving to ovirt-3.6.6 for verification as 3.6.5 is already out.
Comment 17 Shira Maximov 2016-05-09 11:38:55 EDT
please add verification steps
Comment 18 Martin Sivák 2016-05-10 05:00:56 EDT
Check the systemd log for errors during unit loading and try to start momd service.
Comment 19 Shira Maximov 2016-05-19 06:21:43 EDT
verified on :
Red Hat Enterprise Virtualization Manager Version: 3.6.6.2-0.1.el6


verification steps:

service vdsmd stop
service mom-vdsm stop
service momd start
systemctl daemon-reload
journalctl -u momd.service ->> check that there are no errors about the Timeout.

Note You need to log in before you can comment on or make changes to this bug.