Bug 1264034 - Error appears when s2i build with eap-openshift image
Error appears when s2i build with eap-openshift image
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image (Show other bugs)
3.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: kconner
DeShuai Ma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 07:25 EDT by Wenjing Zheng
Modified: 2015-11-23 09:26 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 09:26:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wenjing Zheng 2015-09-17 07:25:45 EDT
Description of problem:
Below info appears when s2i build with eap-openshift image:
I0917 18:59:46.568848 35393 sti.go:407] Downloading: https://repo1.maven.org/maven2/org/jboss/spec/jboss-javaee-6.0/3.0.2.Final-redhat-15/jboss-javaee-6.0-3.0.2.Final-redhat-15.pom
[ERROR] The build could not read 1 project -> [Help 1]
I0917 18:59:47.352898 35393 sti.go:407] org.apache.maven.project.ProjectBuildingException: Some problems were encountered while processing the POMs:
I0917 18:59:47.352914 35393 sti.go:407] [ERROR] Non-resolvable import POM: Could not find artifact org.jboss.spec:jboss-javaee-6.0:pom:3.0.2.Final-redhat-15 in central (https://repo1.maven.org/maven2) @ line 67, column 25
I0917 18:59:47.352921 35393 sti.go:407] [ERROR] 'dependencies.dependency.version' for javax.enterprise:cdi-api:jar is missing. @ line 80, column 21
I0917 18:59:47.352927 35393 sti.go:407] [ERROR] 'dependencies.dependency.version' for org.jboss.spec.javax.annotation:jboss-annotations-api_1.1_spec:jar is missing. @ line 88, column 21
I0917 18:59:47.352933 35393 sti.go:407] [ERROR] 'dependencies.dependency.version' for org.jboss.spec.javax.servlet:jboss-servlet-api_3.0_spec:jar is missing. @ line 95, column 21
I0917 18:59:47.352944 35393 sti.go:407] 
I0917 18:59:47.352951 35393 sti.go:407] 	at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:363)
I0917 18:59:47.352958 35393 sti.go:407] 	at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:636)
I0917 18:59:47.352964 35393 sti.go:407] 	at org.apache.maven.DefaultMaven.getProjectsForMavenReactor(DefaultMaven.java:585)
I0917 18:59:47.352971 35393 sti.go:407] 	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:234)
I0917 18:59:47.352977 35393 sti.go:407] 	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
I0917 18:59:47.352992 35393 sti.go:407] 	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
I0917 18:59:47.352997 35393 sti.go:407] 	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
I0917 18:59:47.353003 35393 sti.go:407] 	at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
I0917 18:59:47.353009 35393 sti.go:407] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
I0917 18:59:47.353015 35393 sti.go:407] 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
I0917 18:59:47.353031 35393 sti.go:407] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
I0917 18:59:47.353038 35393 sti.go:407] 	at java.lang.reflect.Method.invoke(Method.java:497)
I0917 18:59:47.353044 35393 sti.go:407] 	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
I0917 18:59:47.353050 35393 sti.go:407] 	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
I0917 18:59:47.353057 35393 sti.go:407] 	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:414)
I0917 18:59:47.353063 35393 sti.go:407] 	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:357)
I0917 18:59:47.353078 35393 sti.go:407] [ERROR]   
I0917 18:59:47.353084 35393 sti.go:407] [ERROR]   The project org.jboss.quickstarts.eap:jboss-helloworld:6.4.0-SNAPSHOT (/home/jboss/source/pom.xml) has 4 errors
I0917 18:59:47.353091 35393 sti.go:407] [ERROR]     Non-resolvable import POM: Could not find artifact org.jboss.spec:jboss-javaee-6.0:pom:3.0.2.Final-redhat-15 in central (https://repo1.maven.org/maven2) @ line 67, column 25 -> [Help 2]
I0917 18:59:47.353104 35393 sti.go:407] org.apache.maven.model.resolution.UnresolvableModelException: Could not find artifact org.jboss.spec:jboss-javaee-6.0:pom:3.0.2.Final-redhat-15 in central (https://repo1.maven.org/maven2)
I0917 18:59:47.353824 35393 sti.go:407] 	at org.apache.maven.project.ProjectModelResolver.resolveModel(ProjectModelResolver.java:159)
I0917 18:59:47.353844 35393 sti.go:407] 	at org.apache.maven.model.building.DefaultModelBuilder.importDependencyManagement(DefaultModelBuilder.java:953)
I0917 18:59:47.353851 35393 sti.go:407] 	at org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuilder.java:400)
I0917 18:59:47.353857 35393 sti.go:407] 	at org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuilder.java:371)
I0917 18:59:47.353872 35393 sti.go:407] 	at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:560)
I0917 18:59:47.353879 35393 sti.go:407] 	at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:352)
I0917 18:59:47.353885 35393 sti.go:407] 	at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:636)
I0917 18:59:47.353891 35393 sti.go:407] 	at org.apache.maven.DefaultMaven.getProjectsForMavenReactor(DefaultMaven.java:585)
I0917 18:59:47.353896 35393 sti.go:407] 	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:234)
I0917 18:59:47.353902 35393 sti.go:407] 	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
I0917 18:59:47.353908 35393 sti.go:407] 	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
I0917 18:59:47.353913 35393 sti.go:407] 	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
I0917 18:59:47.353919 35393 sti.go:407] 	at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
I0917 18:59:47.353924 35393 sti.go:407] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
I0917 18:59:47.353930 35393 sti.go:407] 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
I0917 18:59:47.353935 35393 sti.go:407] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
I0917 18:59:47.353940 35393 sti.go:407] 	at java.lang.reflect.Method.invoke(Method.java:497)
I0917 18:59:47.353946 35393 sti.go:407] 	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
I0917 18:59:47.353952 35393 sti.go:407] 	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
I0917 18:59:47.353957 35393 sti.go:407] 	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:414)
I0917 18:59:47.353967 35393 sti.go:407] 	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:357)
I0917 18:59:47.353975 35393 sti.go:407] Caused by: org.sonatype.aether.resolution.ArtifactResolutionException: Could not find artifact org.jboss.spec:jboss-javaee-6.0:pom:3.0.2.Final-redhat-15 in central (https://repo1.maven.org/maven2)
I0917 18:59:47.353981 35393 sti.go:407] 	at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:538)
I0917 18:59:47.353986 35393 sti.go:407] 	at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:216)
I0917 18:59:47.353995 35393 sti.go:407] 	at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:193)
I0917 18:59:47.354028 35393 sti.go:407] 	at org.sonatype.aether.impl.internal.DefaultRepositorySystem.resolveArtifact(DefaultRepositorySystem.java:286)
I0917 18:59:47.354042 35393 sti.go:407] 	at org.apache.maven.project.ProjectModelResolver.resolveModel(ProjectModelResolver.java:155)
I0917 18:59:47.354056 35393 sti.go:407] 	... 20 more
I0917 18:59:47.354278 35393 sti.go:407] Caused by: org.sonatype.aether.transfer.ArtifactNotFoundException: Could not find artifact org.jboss.spec:jboss-javaee-6.0:pom:3.0.2.Final-redhat-15 in central (https://repo1.maven.org/maven2)
I0917 18:59:47.354291 35393 sti.go:407] 	at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$4.wrap(WagonRepositoryConnector.java:947)
I0917 18:59:47.354297 35393 sti.go:407] 	at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$4.wrap(WagonRepositoryConnector.java:939)
I0917 18:59:47.354303 35393 sti.go:407] 	at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$GetTask.run(WagonRepositoryConnector.java:669)
I0917 18:59:47.354309 35393 sti.go:407] 	at org.sonatype.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:60)
I0917 18:59:47.354314 35393 sti.go:407] 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
I0917 18:59:47.354323 35393 sti.go:407] 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
I0917 18:59:47.354343 35393 sti.go:407] 	at java.lang.Thread.run(Thread.java:745)
I0917 18:59:47.354595 35393 sti.go:407] [ERROR]     'dependencies.dependency.version' for javax.enterprise:cdi-api:jar is missing. @ line 80, column 21
I0917 18:59:47.354607 35393 sti.go:407] [ERROR]     'dependencies.dependency.version' for org.jboss.spec.javax.annotation:jboss-annotations-api_1.1_spec:jar is missing. @ line 88, column 21
I0917 18:59:47.354879 35393 sti.go:407] [ERROR]     'dependencies.dependency.version' for org.jboss.spec.javax.servlet:jboss-servlet-api_3.0_spec:jar is missing. @ line 95, column 21
I0917 18:59:47.354892 35393 sti.go:407] [ERROR] 
I0917 18:59:47.354905 35393 sti.go:407] [ERROR] Re-run Maven using the -X switch to enable full debug logging.
I0917 18:59:47.354911 35393 sti.go:407] [ERROR] 
I0917 18:59:47.354924 35393 sti.go:407] [ERROR] For more information about the errors and possible solutions, please read the following articles:
I0917 18:59:47.355097 35393 sti.go:407] [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
I0917 18:59:47.355109 35393 sti.go:407] [ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException
I0917 18:59:47.371404 35393 sti.go:407] Aborting due to error code 1 from Maven build
I0917 18:59:47.543507 35393 docker.go:450] Container wait returns with 1 and <nil>
I0917 18:59:47.543541 35393 docker.go:457] Container exited
I0917 18:59:48.643955 35393 cleanup.go:23] Removing temporary directory /tmp/sti674810655
I0917 18:59:48.643989 35393 fs.go:99] Removing directory '/tmp/sti674810655'
I0917 18:59:48.645719 35393 main.go:354] An error occurred: non-zero (13) exit code from rcm-img-docker01.build.eng.bos.redhat.com:5001/jboss-eap-6/eap-openshift:6.4-3.0_2

Version-Release number of selected component (if applicable):
eap-openshift:6.4-3.0_2 5c93a30f18d0

How reproducible:
always

Steps to Reproduce:
1. ./sti build -e "MAVEN_ARGS=clean package" --loglevel=5 --ref"=6.4.x" --force-pull=false --context-dir="helloworld" https://github.com/jboss-developer/jboss-eap-quickstarts jboss-eap-6/eap-openshift:6.4-3.0_2 test-jee-app


Actual results:
Container exits with errors.

Expected results:
The container should be built like with image 0849b9a8dc7c.

Additional info:
Comment 2 kconner 2015-10-21 12:33:43 EDT
The MAVEN_OPTS used by the sti build are

-e -Popenshift -DskipTests -Dcom.redhat.xpaas.repo.redhatga package

If you choose to override these then you must ensure you include the appropriate parts (profile, redhatga flag)
Comment 4 Wang Haoran 2015-10-27 05:47:25 EDT
verified with the command :

s2i build -e "MAVEN_ARGS=-Popenshift -DskipTests -Dcom.redhat.xpaas.repo.redhatga package" --loglevel=5 --ref"=6.4.x" --force-pull=false --context-dir="helloworld" https://github.com/jboss-developer/jboss-eap-quickstarts registry.access.redhat.com/jboss-eap-6/eap62-openshift test-jee-app
Comment 5 Brenton Leanhardt 2015-11-23 09:26:57 EST
This fix is available in OpenShift Enterprise 3.1.

Note You need to log in before you can comment on or make changes to this bug.