Bug 1264058 - lorax should support .repo files for input
lorax should support .repo files for input
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 08:12 EDT by Anatoly Litovsky
Modified: 2015-12-11 19:36 EST (History)
4 users (show)

See Also:
Fixed In Version: lorax-24.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-11 19:36:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anatoly Litovsky 2015-09-17 08:12:23 EDT
Description of problem:
The format of repos statement inside json file differ between
treecompose command and installer command

In case of treecompose repo names must be speicified
"repos": ["ovirt-3.5", "ovirt-3.5-epel" ,"fabiand-ovirt-tree-hacks"],

In case of installer the file basnames must be specified.
"repos": ["ovirt-3.5","fabiand-ovirt-tree-hacks"],

Here is the repo file named ovirt-3.5.repo
------------cut here----------------------
[ovirt-3.5]
name=Latest oVirt 3.5 Release
#baseurl=http://resources.ovirt.org/pub/ovirt-3.5/rpm/el7/
mirrorlist=http://resources.ovirt.org/pub/yum-repo/mirrorlist-ovirt-3.5-el7
enabled=1
skip_if_unavailable=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-ovirt-3.5
[ovirt-3.5-epel]
name=Extra Packages for Enterprise Linux 7 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=$basearch
failovermethod=priority
enabled=1
includepkgs=epel-release,python-uinput,puppet,python-lockfile,python-cpopen,python-ordereddict,python-pthreading,python-inotify,python-argparse,novnc,python-ply,python-kitchen,python-daemon,python-websockify,livecd-tools,spice-html5,mom,python-IPy,python-ioprocess,ioprocess,python-paramiko,python-crypto,python-cheetah,python-ecdsa,python-markdown,rubygem-rgen,ovirt-guest-agent,userspace-rcu,protobuf-java
gpgcheck=1
gpgkey=https://dl.fedoraproject.org/pub/epel/RPM-GPG-KEY-EPEL-7

[ovirt-3.5-glusterfs-epel]
name=GlusterFS is a clustered file-system capable of scaling to several petabytes.
baseurl=http://download.gluster.org/pub/gluster/glusterfs/LATEST/EPEL.repo/epel-7/$basearch/
enabled=1
skip_if_unavailable=1
gpgcheck=1
gpgkey=http://download.gluster.org/pub/gluster/glusterfs/LATEST/EPEL.repo/pub.key

[ovirt-3.5-glusterfs-noarch-epel]
name=GlusterFS is a clustered file-system capable of scaling to several petabytes.
baseurl=http://download.gluster.org/pub/gluster/glusterfs/LATEST/EPEL.repo/epel-7/noarch
enabled=1
skip_if_unavailable=1
gpgcheck=1
gpgkey=http://download.gluster.org/pub/gluster/glusterfs/LATEST/EPEL.repo/pub.key

[ovirt-3.5-patternfly1-noarch-epel]
name=Copr repo for patternfly1 owned by patternfly
baseurl=http://copr-be.cloud.fedoraproject.org/results/patternfly/patternfly1/epel-7-$basearch/
enabled=1
skip_if_unavailable=1
gpgcheck=0
Comment 1 Colin Walters 2015-09-17 10:41:32 EDT
True.  I think by convention we've so far used reponame == filename.

But to make this work nicely, lorax would learn how to handle .repo files.
Comment 2 Colin Walters 2015-09-17 10:41:55 EDT
Brian, do you want this on lorax?
Comment 3 Brian Lane 2015-09-17 12:28:08 EDT
Please explain the problem in more detail. dnf handles the repo files in lorax, and lorax doesn't create any repo files.
Comment 4 Colin Walters 2015-09-17 16:52:39 EDT
The issue is that lorax takes `-s` arguments which are repo URLs only, it doesn't expose the equivalent of --setopt=reposdir=/path/to/repos and --enablerepo.

rpm-ostree does things this way, as does yum.
Comment 5 Colin Walters 2015-09-17 17:16:17 EDT
Supporting .repo files would ensure lorax would be able to check GPG keys, support TLS pinning etc.

But probably the most important is it would allow system builders to consistently use .repo files for input.
Comment 6 Brian Lane 2015-11-16 20:39:21 EST
Ends up this isn't too hard to add:

https://github.com/rhinstaller/lorax/pull/69

Note You need to log in before you can comment on or make changes to this bug.