This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1264090 - Copying container content is failing because of missing secrets mount [NEEDINFO]
Copying container content is failing because of missing secrets mount
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.1
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 09:43 EDT by Federico Simoncelli
Modified: 2015-11-17 18:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 18:13:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
fsimonce: needinfo? (dwalsh)


Attachments (Terms of Use)

  None (edit)
Description Federico Simoncelli 2015-09-17 09:43:56 EDT
Description of problem:
Copying container content is failing because of missing secrets mount.

Version-Release number of selected component (if applicable):
docker-1.7.1-108.el7

How reproducible:
100%

Steps to Reproduce:

$ docker create --name=test1 docker.io/fedora:22 bash
$ docker cp test1:/ - | tar t
Error response from daemon: stat
/var/lib/docker/containers/95da2f313ea963972f9b60144b22ebba2c9201f9fd834fa658d218dc51006722/secrets:
no such file or directory
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors


Actual results:
Container content copy fails with "no such file or directory"

Expected results:
Container content copy should succeed.


Additional info:
This defect has been introduced with the patch: ed76152 Add RHEL super secrets patch
Comment 2 Daniel Walsh 2015-09-17 10:28:58 EDT
The current github for rhel7-1.8 an rhel7-1.9 have a fix for this. Please update the packages.
Comment 3 Daniel Walsh 2015-09-28 14:21:16 EDT
Fixed in docker-1.8.2
Comment 5 Lokesh Mandvekar 2015-11-17 18:13:11 EST
Shipped in 7.1.6

Note You need to log in before you can comment on or make changes to this bug.