Bug 1264092 - Copying container content is failing because of missing secrets mount
Copying container content is failing because of missing secrets mount
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: docker (Show other bugs)
22
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Lokesh Mandvekar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 09:45 EDT by Federico Simoncelli
Modified: 2016-02-16 14:54 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 14:54:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Federico Simoncelli 2015-09-17 09:45:45 EDT
Description of problem:
Copying container content is failing because of missing secrets mount.

Version-Release number of selected component (if applicable):
docker-1.8.2-1.gitf1db8f2.fc22.x86_64

How reproducible:
100%

Steps to Reproduce:

$ docker create --name=test1 docker.io/fedora:22 bash
$ docker cp test1:/ - | tar t
Error response from daemon: stat
/var/lib/docker/containers/95da2f313ea963972f9b60144b22ebba2c9201f9fd834fa658d218dc51006722/secrets:
no such file or directory
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors


Actual results:
Container content copy fails with "no such file or directory"

Expected results:
Container content copy should succeed.


Additional info:
This defect has been introduced with the patch: ed76152 Add RHEL super secrets patch
Comment 1 Daniel Walsh 2015-09-17 10:30:42 EDT
The current github for fedora-1.8 an rfedora-1.9 have a fix for this. Please update the packages.
Comment 2 Daniel Walsh 2015-09-29 10:51:12 EDT
FIxed in docker-1.8.2
Comment 3 Mooli Tayer 2015-10-26 05:02:05 EDT
Looks like i'm getting the same error with 1.8.2:
$ docker -v
Docker version 1.8.2-fc22, build f1db8f2/1.8.2
$ sudo docker create --name=test1 docker.io/fedora:22 bash
dfffc62ec260e26172426a6ab51ab8150173ebbcb5b8f7115f9d7185bbf9aa90
$ sudo docker cp test1:/ - 
Error response from daemon: stat /var/lib/docker/containers/dfffc62ec260e26172426a6ab51ab8150173ebbcb5b8f7115f9d7185bbf9aa90/secrets: no such file or directory
Comment 4 Mooli Tayer 2015-10-26 05:20:47 EDT
Resolved on a newer build currently in fedora-testing:
docker-1.8.2-7.gitcb216be.fc22.x86_64

(erroneous one was 1.8.2-1.gitf1db8f2.fc22)
Comment 5 Daniel Walsh 2015-10-26 09:28:19 EDT
Please update karma.
Comment 6 Mooli Tayer 2015-10-26 11:57:54 EDT
(In reply to Daniel Walsh from comment #5)
> Please update karma.

much karma! wow!

https://bodhi.fedoraproject.org/updates/FEDORA-2015-31f3421339

Note You need to log in before you can comment on or make changes to this bug.