Bug 1264126 - missing maven.pom
missing maven.pom
Status: CLOSED NOTABUG
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-java-common (Show other bugs)
rh-java-common
Unspecified Unspecified
unspecified Severity unspecified
: alpha
: 2.1
Assigned To: Java maintainers
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 10:38 EDT by Levente Farkas
Modified: 2015-09-17 14:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-17 14:09:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2015-09-17 10:38:29 EDT
while i try to build jna for epel7 i've got an error for this macro:

%add_maven_depmap JPP-%{name}.pom %{name}.jar

the error was:
-------------------
+ set -e
+ _pompart=JPP-jna.pom
+ _jarpart=jna.jar
+ _filelist=.mfiles
+ install -dm 755 /home/lfarkas/rpm/BUILDROOT/jna-4.2.0-1.el7.centos.x86_64/usr/share/maven-metadata
+ for _dir in /usr/lib/java '%{_javajnidir}' /usr/share/java
+ '[' -f /home/lfarkas/rpm/BUILDROOT/jna-4.2.0-1.el7.centos.x86_64/usr/lib/java/jna.jar ']'
+ for _dir in /usr/lib/java '%{_javajnidir}' /usr/share/java
+ '[' -f '/home/lfarkas/rpm/BUILDROOT/jna-4.2.0-1.el7.centos.x86_64%{_javajnidir}/jna.jar' ']'
+ for _dir in /usr/lib/java '%{_javajnidir}' /usr/share/java
+ '[' -f /home/lfarkas/rpm/BUILDROOT/jna-4.2.0-1.el7.centos.x86_64/usr/share/java/jna.jar ']'
+ _jpath=/home/lfarkas/rpm/BUILDROOT/jna-4.2.0-1.el7.centos.x86_64/usr/share/java/jna.jar
+ /usr/bin/python /opt/rh/rh-java-common/root/usr/share/java-utils/maven_depmap.py -n '' /home/lfarkas/rpm/BUILDROOT/jna-4.2.0-1.el7.centos.x86_64/usr/share/maven-metadata/jna.xml /home/lfarkas/rpm/BUILDROOT/jna-4.2.0-1.el7.centos.x86_64/usr/share/maven-poms/JPP-jna.pom /home/lfarkas/rpm/BUILDROOT/jna-4.2.0-1.el7.centos.x86_64/usr/share/java/jna.jar
Traceback (most recent call last):
  File "/opt/rh/rh-java-common/root/usr/share/java-utils/maven_depmap.py", line 49, in <module>
    from javapackages.maven.pom import POM
ImportError: No module named maven.pom
-------------------
Comment 1 Mikolaj Izdebski 2015-09-17 10:46:01 EDT
Are you trying to use software collections to build packages for EPEL? As far as I know that's not supported.

From the stack trace it looks like SCL was not enabled prior to using it. Did you enable software collection before using the macro?
Comment 2 Levente Farkas 2015-09-17 10:54:10 EDT
i use the software collection's latest packages. i'd like to build a package which install maven depmap but wouldn't like to build scl package ie. put it under normal path.

i'd like to build tha same package for fedora and epel:
https://admin.fedoraproject.org/pkgdb/package/jna/
fedora build was successful:
http://koji.fedoraproject.org/koji/buildinfo?buildID=685193
and i'd like to build the same for epel-(6|7) too. is there any other way then using software collection's rh-java-common-javapackages-tools?
Comment 3 Mikolaj Izdebski 2015-09-17 11:09:40 EDT
Every software collection must be enabled before use. Please try with SCL enabled.
Comment 4 Levente Farkas 2015-09-17 14:09:52 EDT
ok i remove maven support on epel. it's easier.

Note You need to log in before you can comment on or make changes to this bug.