Bug 126413 - Would be nice to have a date-related rotated log filename
Would be nice to have a date-related rotated log filename
Status: CLOSED DUPLICATE of bug 126693
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: logrotate (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-21 07:00 EDT by Need Real Name
Modified: 2015-01-07 19:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SUSE's logrotate patch (8.29 KB, patch)
2004-12-10 12:05 EST, David Anderson
no flags Details | Diff

  None (edit)
Description Need Real Name 2004-06-21 07:00:53 EDT
Description of problem:
It would be nice if logrotate has an inbuilt option to show date 
information in the filename of a rotated log.
Comment 1 Suzanne Hillman 2004-06-24 16:41:08 EDT
Internal RFE bug #126693 entered; will be considered for future releases.
Comment 2 Elliot Lee 2004-07-16 15:33:38 EDT

*** This bug has been marked as a duplicate of 126693 ***
Comment 4 David Anderson 2004-12-10 11:34:49 EST
As we can't view the internal RFE bug, can you tell us if there is 
any progress on this? Might we see it in Fedora some time? 
Comment 5 Elliot Lee 2004-12-10 11:48:35 EST
The basic deal is that we (well, gafton) /are/ upstream for logrotate,
so it's a matter of working up acceptable patches and then persuading
us to include them.

I'm pretty sure there have been other bugs opened around this issue -
it's worth searching through bugzilla to find them and figure out what
the total picture is right now.

Thanks for your patience.
Comment 6 David Anderson 2004-12-10 12:05:50 EST
Created attachment 108329 [details]
SUSE's logrotate patch
Comment 7 David Anderson 2004-12-10 12:07:12 EST
I've found 2 other bugzilla entries:  
81819 (14 Jan 2003 - DEFERRED)  
108775 (1 Jan 2003 - ASSIGNED)  
  
The latter has discussion of SUSE's patch that adds a "dateext"  
option. There were some people who said it was pointless, and replies  
pointing out that it's only an option (not compulsary), and the  
real-world benefits (e.g. I rsync logfiles from another continent -  
big bandwidth savings). There was a question over whether it played  
well with one of the logrotate options, and assurances that it did.  
  
I've attached SUSE's patch to logrotate 3.7 (extracted from  
ftp://ftp.suse.com/pub/people/ro/logrotate/logrotate-3.7-31.2.src.rpm)  
to this comment. SUSE have been using it since December 2001; I'm not 
a coder so can't really comment, but I'd have thought that it must be 
fairly reliable on the basis of its longevity alone. 
Comment 8 Elliot Lee 2004-12-10 12:14:34 EST
Good point about longevity... Looks like Petr owns logrotate now - no idea what
his schedule is like. #108775 is "the bug" tracking this issue, though.
Comment 9 Red Hat Bugzilla 2006-02-21 14:04:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.