Bug 1264196 - wrong command in /etc/cron.daily/docker-logrotate
wrong command in /etc/cron.daily/docker-logrotate
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: docker (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Lokesh Mandvekar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 16:18 EDT by Lokesh Mandvekar
Modified: 2015-10-28 10:12 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1261329
Environment:
Last Closed: 2015-10-28 10:12:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lokesh Mandvekar 2015-09-17 16:18:25 EDT
+++ This bug was initially created as a clone of Bug #1261329 +++

Description of problem:

In /etc/cron.daily/docker-logrotate which is created after installing docker-logrotate, there is a following setting:

  exec $(docker exec $id logrotate -s /var/log/logstatus /etc/logrotate.conf > /dev/null 2&>1)

It should be:

  exec $(docker exec $id logrotate -s /var/log/logstatus /etc/logrotate.conf > /dev/null 2>&1)

Additional info:

# rpm -qa |grep docker
docker-1.7.1-108.el7.x86_64
docker-selinux-1.7.1-108.el7.x86_64
docker-logrotate-1.7.1-108.el7.x86_64
docker-registry-0.9.1-4.el7.x86_64

--- Additional comment from RHEL Product and Program Management on 2015-09-09 03:27:42 CDT ---

Since this bug report was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from Daniel Walsh on 2015-09-09 09:01:57 CDT ---



--- Additional comment from Daniel Walsh on 2015-09-09 09:02:23 CDT ---
Comment 1 Daniel Walsh 2015-09-29 09:11:23 EDT
Any movement on this?
Comment 2 Daniel Walsh 2015-10-28 10:04:04 EDT
Lokesh is this fixed in docker-1.8?
Comment 3 Lokesh Mandvekar 2015-10-28 10:12:49 EDT
yes

Note You need to log in before you can comment on or make changes to this bug.