Bug 1264235 - [ru-RU][ja-JP][fr-FR][es-ES] Unable to provide common translation for <return>, tag errors
[ru-RU][ja-JP][fr-FR][es-ES] Unable to provide common translation for <return...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Translation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 20:25 EDT by Noriko Mizumoto
Modified: 2015-10-23 13:45 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-23 13:45:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noriko Mizumoto 2015-09-17 20:25:19 EDT
Description of problem:
"return" key is generally called "enter" key in Russian and Japanese. But because "return" is tagged, errors generated when it changed in the translation.
https://fedora.zanata.org/iteration/view/anaconda/master

Version-Release number of selected component (if applicable):
n/a

How reproducible:
always

Actual results:
Translating <return> as <enter> generates errors.

Expected results:
"return" is translatable as "enter", for example by removing tags 

Additional info:
Comment 1 Vojtech Trefny 2015-09-18 03:12:09 EDT
I see the same problem in Czech localization, but it actually doesn't produce an error, just a warning and I think we just could simply ignore it.

------
Warnings: 2, Error: none

    Missing tag: <return>
    Unexpected tag: <Enter>
------

The warnings don't seem to affect generated PO files:

------
#: anaconda:466
msgid ""
"\n"
"Press <return> to reboot your system.\n"
msgstr ""
"\n"
"Stisknutím tlačítka <Enter> restartujte systém.\n"
------
Comment 2 David Shea 2015-09-18 09:11:32 EDT
We had a conversation with docs and found that "Enter" is preferred over "Return" in the documentation, so we'll make the change. But where is the warning coming from? It looks like something is misinterpreting the string.
Comment 3 David Shea 2015-09-21 16:34:07 EDT
Setting needinfo for the question in comment 2.
Comment 4 Patrick Huang 2015-09-22 20:27:04 EDT
Whether Zanata show it as error or warning depends on the project/version settings. Zanata offers a range of translation validation rules. The relevant one for this particular case is "HTML/XML tags". i.e. translation string must match all the tags in source string. 

If project maintainer sets this validation rule to be "Error", any mismatch of tags in translation will generate an error in Zanata and translation can not be saved (provided the validation rule is set before translation is entered). If the validation rule is set to be "Warning", it will generate an warning but translator can still save the string. 

"HTML/XML tags" validation rule is generally more suitable to set as Error on docbook or html projects, where the tag will affect final output. If tag usage is mainly as decoration of a word, it's recommended to set as Warning so translator can choose appropriate translation.
Comment 5 David Shea 2015-10-07 10:39:20 EDT
https://github.com/rhinstaller/anaconda/pull/394 to fix the errors on the master branch. Confirmed with sbueno that F23 is set to warning.

anaconda does use a lot of XML tags in pango markup so we would like it to be validated in the translated strings.
Comment 6 David Shea 2015-10-08 10:48:55 EDT
Resetting status since this is more of a Zanata configuration issue than a string issue.
Comment 7 David Shea 2015-10-23 13:45:41 EDT
Confirmed with bcl and sbueno that our zanata configuration is set to warn about tag mis-matches, which is what we want. It will continue to warn about this one, which is the consequence of keeping the warnings about all of the actual tags in anaconda.

Note You need to log in before you can comment on or make changes to this bug.