Bug 1264268 - Using startupPolicy='optional' with USB passthrough stopped working
Using startupPolicy='optional' with USB passthrough stopped working
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 01:27 EDT by Dax Kelson
Modified: 2016-04-26 17:42 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-26 17:42:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2015-09-18 01:27:03 EDT
Description of problem:

On a updated Fedora 22 machine I have a VM with several USB passthrough devices.

For example:

    <hostdev mode='subsystem' type='usb' managed='yes'>
      <source startupPolicy='optional'>
        <vendor id='0x0403'/>
        <product id='0x6001'/>
      </source>
    </hostdev>

I plugged the above device (a USB serial port) in and tried booting the VM and got a libvirt error (and VM wouldn't start):

Sep 17 23:06:56 mentor libvirtd[2127]: internal error: Device 003:020 is already in use
Sep 17 23:06:56 mentor libvirtd[2127]: Unable to find device 003.020 in list of active USB devices
Sep 17 23:06:56 mentor libvirtd[2127]: Unable to find device 003.020 in list of active USB devices
Sep 17 23:06:56 mentor libvirtd[2127]: Unable to find device 000.000 in list of active USB devices
Sep 17 23:06:56 mentor libvirtd[2127]: Unable to find device 000.000 in list of active USB devices

I removed the startupPolicy='optional' attribute and the VM starts with no error. Weird.

So to recap:

USB device plugged in AND startupPolicy='optional' = FAILURE TO START
USB device plugged in AND NO startupPolicy='optional' = OK
USB device not plugged in AND startupPolicy='optional' = OK

I've been able to use the startupPolicy='optional' with a several USB devices for a couple years, but it has been since April (6 months ago -- on Fedora 21) that attempted (and it worked).
Comment 1 Cole Robinson 2016-04-13 19:51:04 EDT
Sorry this didn't receive a timely response. I can't reproduce on f22 or f23. Are you still hitting this issue?
Comment 2 Cole Robinson 2016-04-26 17:42:36 EDT
Closing as WORKSFORME, but if anyone can still reproduce with latest packages, please reopen

Note You need to log in before you can comment on or make changes to this bug.