Bug 1264277 - No man page for meta package
No man page for meta package
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: devtoolset-meta (Show other bugs)
DTS 4.0 RHEL 7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 4.0
Assigned To: Marek Polacek
Martin Cermak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 01:41 EDT by Honza Horak
Modified: 2015-11-16 10:36 EST (History)
4 users (show)

See Also:
Fixed In Version: devtoolset-4-4.0-6.el7
Doc Type: Enhancement
Doc Text:
The Developer Toolset meta package now comes with a manual page.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 10:36:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Honza Horak 2015-09-18 01:41:34 EDT
Description of problem:
In RHSCL we usually have a simple man page that describes how to use the collection and SCL generally. Wouldn't something like that be good also for devtoolset users?

Example of one of the man pages:

NAME
       rh-mongodb26 - manual page for rh-mongodb26 2.0 Software Collection

SYNOPSIS
       scl enable rh-mongodb26 'mongod'

DESCRIPTION
       Package  rh-mongodb26  provides  MongoDB  server  delivered  as a Software Collection. For more information about Software Collections, see the scl(1) man page. By installing the
       rh-mongodb26 collection, you will get the minimum working set of packages to have a working MongoDB server.

       Software Collections allow you to build and execute applications which are not located in the filesystem root hierarchy, but are stored  in  an  alternative  location,  which  is
       /opt/rh/rh-mongodb26/root in case of the rh-mongodb26 collection.

       This package provides the mongod server daemon and the mongos sharding server daemon software, default configuration files and init scripts.

       When you want to work with the rh-mongodb26 collection, use the scl utility (see the scl(1) man page for usage) to enable the scl environment.

       Configuration for the rh-mongodb26 software collection is located under /etc/opt/rh/rh-mongodb26 .

EXAMPLES
       scl enable rh-mongodb26 'command --arg'

              Run a specific command with the argument --arg within the rh-mongodb26 software collections environment.

       scl enable rh-mongodb26 'mongod'

              Run mongod from the rh-mongodb26 software collection.

       scl enable rh-mongodb26 'bash'

              Run an interactive shell wherein the rh-mongodb26 software collection is enabled.

       scl enable rh-mongodb26 'man mongod'

              Show man pages for the mongod command, which is a part of the rh-mongodb26 software collection.

REPORTING BUGS
       Report bugs to <http://bugzilla.redhat.com>.
Comment 7 errata-xmlrpc 2015-11-16 10:36:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2046.html

Note You need to log in before you can comment on or make changes to this bug.