Bug 1264311 - After reset the cartridges : jboss-wildfly-8\jboss-wildfly-9\jboss-dv-6.1.0 were absent on STG env.
After reset the cartridges : jboss-wildfly-8\jboss-wildfly-9\jboss-dv-6.1.0 w...
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: John W. Lamb
DeShuai Ma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 03:16 EDT by zhou ying
Modified: 2017-05-31 14:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-31 14:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhou ying 2015-09-18 03:16:12 EDT
Description of problem:
After reset ,the cartridges : jboss-wildfly-8\jboss-wildfly-9\jboss-dv-6.1.0  were absent on STG env.

Version-Release number of selected component (if applicable):
STG

How reproducible:
always

Steps to Reproduce:
1. Login the reset STG env;
2. List all the cartridges on STG:
  `rhc cartridge list`

Actual results:
[zhouy@zhouy Documents]$ rhc server-show stg.openshift.redhat.com
Server 'stg' (in use)
---------------------
  Hostname:        stg.openshift.redhat.com
  Login:           libra-test+power29@redhat.com
  Use Auth Tokens: true
  Insecure:        true
[zhouy@zhouy Documents]$ rhc cartridge list
jbossas-7                JBoss Application Server 7              web
jboss-dv-6.0.0 (!)       JBoss Data Virtualization 6             web
jbosseap-6 (*)           JBoss Enterprise Application Platform 6 web
jboss-unified-push-2 (!) JBoss Unified Push Server 1.0.0.Beta2   web
jenkins-1                Jenkins Server                          web
nodejs-0.10              Node.js 0.10                            web
perl-5.10                Perl 5.10                               web
php-5.3                  PHP 5.3                                 web
php-5.4                  PHP 5.4                                 web
zend-6.1                 PHP 5.4 with Zend Server 6.1            web
python-2.6               Python 2.6                              web
python-2.7               Python 2.7                              web
python-3.3               Python 3.3                              web
ruby-1.8                 Ruby 1.8                                web
ruby-1.9                 Ruby 1.9                                web
ruby-2.0                 Ruby 2.0                                web
jbossews-1.0             Tomcat 6 (JBoss EWS 1.0)                web
jbossews-2.0             Tomcat 7 (JBoss EWS 2.0)                web
jboss-vertx-2.1 (!)      Vert.x 2.1                              web
diy-0.1                  Do-It-Yourself 0.1                      web
cron-1.4                 Cron 1.4                                addon
jenkins-client-1         Jenkins Client                          addon
mongodb-2.4              MongoDB 2.4                             addon
mysql-5.1                MySQL 5.1                               addon
mysql-5.5                MySQL 5.5                               addon
phpmyadmin-4             phpMyAdmin 4.0                          addon
postgresql-8.4           PostgreSQL 8.4                          addon
postgresql-9.2           PostgreSQL 9.2                          addon
rockmongo-1.1            RockMongo 1.1                           addon
switchyard-0             SwitchYard 0.8.0                        addon
haproxy-1.4              Web Load Balancer                       addon

Expected results:
Should contain the cartridges in lists:jboss-wildfly-8\jboss-wildfly-9\jboss-dv-6.1.0

Additional info:
Comment 1 Stefanie Forrester 2015-10-19 18:41:49 EDT
I'm still seeing this issue on the client side. Though, strangely, it was not present on the broker when I checked there.

[dakini@samadhi ~]$ rhc server-show stg.openshift.redhat.com
Server 'stg' (in use)
---------------------
  Hostname:    stg.openshift.redhat.com
  Login:       sedgar+2@redhat.com
  SSL Version: TLSv1
[dakini@samadhi ~]$ rhc cartridge list |grep -e jboss-wildfly-8 -e jboss-wildfly-9 -e jboss-dv-6.1.0
[dakini@samadhi ~]$

[root@use-srv1.stg ~]# rhc cartridge list |grep -e jboss-wildfly-8 -e jboss-wildfly-9 -e jboss-dv-6.1.0
You have not yet configured the OpenShift client tools. Please run 'rhc setup'.
jboss-dv-6.1.0 (!)       JBoss Data Virtualization 6             web
jboss-wildfly-8 (!)      WildFly Application Server 8.2.1.Final  web
jboss-wildfly-9 (!)      WildFly Application Server 9            web
Comment 2 Stefanie Forrester 2015-10-19 18:53:44 EDT
This was happening in INT as well, according to bug #1263952, but after deploying the latest release, the issue has gone away. I think we should wait and see if the STG deploy fixes the bug, since the latest release seems to have resolved it in INT.

https://bugzilla.redhat.com/show_bug.cgi?id=1263952#c1
Comment 5 Stefanie Forrester 2015-10-27 11:35:28 EDT
After the STG deploy, I ended up manually importing this:

oo-admin-ctl-cartridge -c import --activate -u https://raw.github.com/openshift-cartridges/openshift-wildfly-cartridge/wildfly-9/metadata/manifest.yml

Then I could see all of the cartridges from the client tool:

[dakini@samadhi ~]$ rhc server-show stg.openshift.redhat.com
Server 'stg' (in use)
---------------------
  Hostname:    stg.openshift.redhat.com
  Login:       sedgar+2@redhat.com
  SSL Version: TLSv1

[dakini@samadhi ~]$ rhc cartridge list |grep -e jboss-wildfly-8 -e jboss-wildfly-9 -e jboss-dv-6.1.0
jboss-dv-6.1.0 (!)       JBoss Data Virtualization 6             web
jboss-wildfly-8 (!)      WildFly Application Server 8.2.1.Final  web
jboss-wildfly-9 (!)      WildFly Application Server 9            web

Please confirm issue is resolved, thanks!
Comment 6 zhou ying 2015-10-27 22:33:25 EDT
confirmed ON latest STG env:
[zhouy@zhouy Desktop]$ rhc server-show stg.openshift.redhat.com
Server 'stg' (in use)
---------------------
  Hostname:        stg.openshift.redhat.com
  Login:           yinzhou@redhat.com
  Use Auth Tokens: true
  Insecure:        true

Use 'rhc servers' to display all your servers.

[zhouy@zhouy Desktop]$ rhc cartridge-list
jbossas-7                JBoss Application Server 7              web
jboss-dv-6.1.0 (!)       JBoss Data Virtualization 6             web
jboss-dv-6.0.0 (!)       JBoss Data Virtualization 6             web
jbosseap-6 (*)           JBoss Enterprise Application Platform 6 web
jboss-unified-push-2 (!) JBoss Unified Push Server 1.0.0.Beta2   web
jenkins-1                Jenkins Server                          web
nodejs-0.10              Node.js 0.10                            web
perl-5.10                Perl 5.10                               web
php-5.3                  PHP 5.3                                 web
php-5.4                  PHP 5.4                                 web
zend-6.1                 PHP 5.4 with Zend Server 6.1            web
python-2.6               Python 2.6                              web
python-2.7               Python 2.7                              web
python-3.3               Python 3.3                              web
ruby-1.8                 Ruby 1.8                                web
ruby-1.9                 Ruby 1.9                                web
ruby-2.0                 Ruby 2.0                                web
jbossews-1.0             Tomcat 6 (JBoss EWS 1.0)                web
jbossews-2.0             Tomcat 7 (JBoss EWS 2.0)                web
jboss-vertx-2.1 (!)      Vert.x 2.1                              web
jboss-wildfly-10 (!)     WildFly Application Server 10           web
jboss-wildfly-8 (!)      WildFly Application Server 8.2.1.Final  web
jboss-wildfly-9 (!)      WildFly Application Server 9            web
diy-0.1                  Do-It-Yourself 0.1                      web
cron-1.4                 Cron 1.4                                addon
jenkins-client-1         Jenkins Client                          addon
mongodb-2.4              MongoDB 2.4                             addon
mysql-5.1                MySQL 5.1                               addon
mysql-5.5                MySQL 5.5                               addon
phpmyadmin-4             phpMyAdmin 4.0                          addon
postgresql-8.4           PostgreSQL 8.4                          addon
postgresql-9.2           PostgreSQL 9.2                          addon
rockmongo-1.1            RockMongo 1.1                           addon
switchyard-0             SwitchYard 0.8.0                        addon
haproxy-1.4              Web Load Balancer                       addon

Note: Web cartridges can only be added to new applications.
Comment 7 Eric Paris 2017-05-31 14:22:11 EDT
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.

Note You need to log in before you can comment on or make changes to this bug.