Bug 1264359 - Man pages should be installed in arch specific directory
Man pages should be installed in arch specific directory
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mpich (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Zbigniew Jędrzejewski-Szmek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 05:46 EDT by Jonathan Underwood
Modified: 2015-12-06 14:20 EST (History)
2 users (show)

See Also:
Fixed In Version: mpich-3.1.4-7.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-06 14:20:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2015-09-18 05:46:27 EDT
Description of problem:
The mpich package installs its man pages under a non-arch specific directory:

/usr/share/man/mpich/man1

whereas the guidelines[1] state:

As include files and manual pages are bound to overlap between different MPI implementations, they MUST also placed outside normal directories. It is possible that some man pages or include files (either those of the MPI compiler itself or of some MPI software installed in the compiler's directory) are architecture specific (e.g. a definition on a 32-bit arch differs from that on a 64-bit arch), the directories that MUST be used are as follows: 

Man pages 	%{_mandir}/%{name}-%{_arch}%{?_cc_name_suffix}/

The openmpi package gets this right, for reference. So, the man pages need to be moved, and the environment module file updated accordingly.


[1] https://fedoraproject.org/wiki/Packaging:MPI
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-11-16 11:31:13 EST
I don't think arch-specific man pages make much sense, but since the guidelines state "MUST", I'll just follow that.
Comment 2 Fedora Update System 2015-11-16 13:41:01 EST
mpich-3.1.4-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-be322c3755
Comment 3 Fedora Update System 2015-11-18 11:52:43 EST
mpich-3.1.4-7.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mpich'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-be322c3755
Comment 4 Fedora Update System 2015-12-06 14:20:09 EST
mpich-3.1.4-7.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.