Bug 1264382 - windows 8.1/windows2012 r2 fail to specify base="2006-06-17" as RTC time
windows 8.1/windows2012 r2 fail to specify base="2006-06-17" as RTC time
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 06:38 EDT by Xueqiang Wei
Modified: 2017-07-04 21:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 07:28:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xueqiang Wei 2015-09-18 06:38:47 EDT
Description of problem:

Boot win8-64.1/win2012-64r2 guest with -rtc base="2006-06-17",clock=host,driftfix=slew, it doesn't change date inside guest. 

guest windows 7 is ok, guest RHEL7.2 is ok.


I downgrade to qemu-kvm-rhev-2.1.2-23.el7 to try, also hit this issue. 


Version-Release number of selected component (if applicable):
Kernel-3.10.0-314.el7.x86_64
qemu-kvm-rhev-2.3.0-22.el7
seabios-1.7.5-11.el7.x86_64
seabios-bin-1.7.5-11.el7.noarch


How reproducible:
100%


Steps to Reproduce:
1. boot guest w/o network
  # qemu-kvm ... -net none 
2. set time zone to Beijing(UTC +08:00) in guest 
  For linux: 
  # mv /etc/localtime /etc/localtime.bak 
  # ln -sf /usr/share/zoneinfo/Asia/Shanghai /etc/localtime 
  # reboot 
  For Windows: 
  Click time -> 'Change date and time settings' -> 'Change time zone' 
  choose 'UTC +08:00(Beijing, Chongqing)'
3. boot the guest with kvm-clock
/usr/libexec/qemu-kvm \
    -name 'virt-tests-vm1'  \
    -sandbox off  \
    -machine pc  \
    -nodefaults  \
    -vga qxl \
    -device intel-hda,bus=pci.0,addr=03 \
    -device hda-duplex  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20150911-182017-1qMDjwx6,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=qmp_id_catch_monitor,path=/tmp/monitor-catch_monitor-20150911-182017-1qMDjwx6,server,nowait \
    -mon chardev=qmp_id_catch_monitor,mode=control \
    -device pvpanic,ioport=0x505,id=idtlvMTr  \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20150911-182017-1qMDjwx6,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20150911-182017-1qMDjwx6,path=/tmp/seabios-20150911-182017-1qMDjwx6,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20150911-182017-1qMDjwx6,iobase=0x402 \
    -device nec-usb-xhci,id=usb1,bus=pci.0,addr=04 \
    -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,format=raw,file=/home/win8-64.1-virtio.raw \
    -device ide-drive,id=image1,drive=drive_image1 \
    -m 4096  \
    -smp 4,maxcpus=4,cores=2,threads=1,sockets=2  \
    -cpu 'Conroe',+kvm_pv_unhalt,+cx16 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -spice port=3000,disable-ticketing  \
    -boot order=cdn,once=c,menu=off,strict=off \
    -enable-kvm \
    -monitor stdio \
    -rtc base="2006-06-17",clock=host,driftfix=slew  \
    -net none \
4. check the system time in guest and host
  For linux guest
  4.1 # date
  For window guest, in cmd.exe
  4.1 >echo %TIME%

Actual results:
date isn't changed inside guest

Expected results:
guest date is  2006-06-17


Additional info:
cpu info:
processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 15
model name	: Intel(R) Xeon(R) CPU           E5310  @ 1.60GHz
stepping	: 11
microcode	: 0xbc
cpu MHz		: 1595.927
cache size	: 4096 KB
physical id	: 1
siblings	: 4
core id		: 3
cpu cores	: 4
apicid		: 7
initial apicid	: 7
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx tm2 ssse3 cx16 xtpr pdcm dca lahf_lm dtherm tpr_shadow vnmi flexpriority
bogomips	: 3191.89
clflush size	: 64
cache_alignment	: 64
address sizes	: 38 bits physical, 48 bits virtual
power management:
Comment 2 Xueqiang Wei 2015-09-18 07:10:51 EDT
also hit this issue on:
kernel-3.10.0-316.el7.x86_64
qemu-kvm-rhev-2.3.0-23.el7
Comment 4 Yan Vugenfirer 2015-09-22 07:28:32 EDT
Looks like Windows "feature".

1. Windows Server doesn't let to set time "back". You can set it forward just to check that passing a date to -rtc effects Windows OS.

2. Also it is better to disable NTP ("Internet time synchronisation") on Windows when doing time related tests.

Note You need to log in before you can comment on or make changes to this bug.