Bug 1264412 - Installation fails if the CP4 is applied in advance
Installation fails if the CP4 is applied in advance
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Installer, Launch Scripts (Show other bugs)
JON 3.3.4
Unspecified Unspecified
urgent Severity high
: ER01
: JON 3.3.4
Assigned To: Simeon Pinder
Filip Brychta
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 08:05 EDT by Filip Brychta
Modified: 2015-10-29 11:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-29 11:54:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Brychta 2015-09-18 08:05:01 EDT
Description of problem:
Possibility to patch the server before installation (new feature introduce in JON3.3.3) is not working in JON 3.3.4.

Version-Release number of selected component (if applicable):
JON3.3.4.DR01

How reproducible:


Steps to Reproduce:
1. unzip JON3.3.0.GA and CP4 (jon-server-3.3.0.GA-update-04)
2. apply the patch (jon-server-3.3.0.GA-update-04/apply-updates.sh jon-server-3.3.0.GA)
3. install the server (rhqctl install)

Actual results:
08:04:14,324 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] JMS queue [DriftFileQueue] created
08:04:14,332 WARN  [org.rhq.enterprise.server.installer.InstallerServiceImpl] deployServices failed: org.rhq.common.jbossas.client.controller.FailureException: Failed to setup mail service: {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-1" => "JBAS014807: Management resource '[
    (\"subsystem\" => \"mail\"),
    (\"mail-session\" => \"default\")
]' not found"}}
	at org.rhq.enterprise.server.installer.ServerInstallUtil.setupMailService(ServerInstallUtil.java:298) [rhq-installer-util-4.12.0.JON330GA-redhat-3.jar:4.12.0.JON330GA-redhat-3]
	at org.rhq.enterprise.server.installer.InstallerServiceImpl.deployServices(InstallerServiceImpl.java:1395) [rhq-installer-util-4.12.0.JON330GA-redhat-3.jar:4.12.0.JON330GA-redhat-3]
	at org.rhq.enterprise.server.installer.InstallerServiceImpl.install(InstallerServiceImpl.java:471) [rhq-installer-util-4.12.0.JON330GA-redhat-3.jar:4.12.0.JON330GA-redhat-3]
	at org.rhq.enterprise.server.installer.Installer.doInstall(Installer.java:135) [rhq-installer-util-4.12.0.JON330GA-redhat-3.jar:4.12.0.JON330GA-redhat-3]
	at org.rhq.enterprise.server.installer.Installer.main(Installer.java:59) [rhq-installer-util-4.12.0.JON330GA-redhat-3.jar:4.12.0.JON330GA-redhat-3]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.7.0_75]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.7.0_75]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_75]
	at java.lang.reflect.Method.invoke(Method.java:606) [rt.jar:1.7.0_75]
	at org.jboss.modules.Module.run(Module.java:312) [jboss-modules.jar:1.3.7.Final-redhat-1]
	at org.jboss.modules.Main.main(Main.java:473) [jboss-modules.jar:1.3.7.Final-redhat-1]

08:04:14,339 ERROR [org.rhq.enterprise.server.installer.Installer] The installer will now exit due to previous errors: java.lang.Exception: Failed to deploy services: org.rhq.common.jbossas.client.controller.FailureException:Failed to setup mail service: {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-1" => "JBAS014807: Management resource '[
    (\"subsystem\" => \"mail\"),
    (\"mail-session\" => \"default\")
]' not found"}}
	at org.rhq.enterprise.server.installer.InstallerServiceImpl.deployServices(InstallerServiceImpl.java:1408) [rhq-installer-util-4.12.0.JON330GA-redhat-3.jar:4.12.0.JON330GA-redhat-3]
	at org.rhq.enterprise.server.installer.InstallerServiceImpl.install(InstallerServiceImpl.java:471) [rhq-installer-util-4.12.0.JON330GA-redhat-3.jar:4.12.0.JON330GA-redhat-3]
	at org.rhq.enterprise.server.installer.Installer.doInstall(Installer.java:135) [rhq-installer-util-4.12.0.JON330GA-redhat-3.jar:4.12.0.JON330GA-redhat-3]
	at org.rhq.enterprise.server.installer.Installer.main(Installer.java:59) [rhq-installer-util-4.12.0.JON330GA-redhat-3.jar:4.12.0.JON330GA-redhat-3]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.7.0_75]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.7.0_75]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_75]
	at java.lang.reflect.Method.invoke(Method.java:606) [rt.jar:1.7.0_75]
	at org.jboss.modules.Module.run(Module.java:312) [jboss-modules.jar:1.3.7.Final-redhat-1]
	at org.jboss.modules.Main.main(Main.java:473) [jboss-modules.jar:1.3.7.Final-redhat-1]

Trying to stop the RHQ Server...
RHQ Server (pid=20856) is stopping...
RHQ Server has stopped.
RHQ Server                     (no pid file) is ✘down
Stopping RHQ storage node...
RHQ storage node (pid=20641) is stopping...
RHQ storage node has stopped
08:04:26,597 ERROR [org.rhq.server.control.RHQControl] Installer failed with code 2, shut down server
08:04:26,598 WARN  [org.rhq.server.control.command.Install] UNDO: Removing server-installed marker file and management user and reverting to original standalone-full.xml
08:04:26,599 WARN  [org.rhq.server.control.command.Install] UNDO: Stopping component: --server
RHQ Server                     (no pid file) is ✘down
08:04:26,647 WARN  [org.rhq.server.control.command.Install] UNDO: Stopping component: --storage
08:04:26,648 WARN  [org.rhq.server.control.command.Install] UNDO: Removing storage node data and install directories
08:04:26,674 WARN  [org.rhq.server.control.command.Install] UNDO: Reverting server properties file

Expected results:
No errors
Comment 1 Simeon Pinder 2015-09-30 11:03:13 EDT
This should be fixed with commit: fb59c81862d437 to jon.git. Moving to MODIFIED.
The fix was to retry the earlier batch request with the 6.3 format as well before failing completely.
Comment 2 Simeon Pinder 2015-10-09 00:40:09 EDT
Moving to ON_QA as available to test with the following build:
https://brewweb.devel.redhat.com/buildinfo?buildID=460382

 *Note: jon-server-patch-3.3.0.GA.zip maps to ER01 build of
 jon-server-3.3.0.GA-update-04.zip.
Comment 3 Filip Brychta 2015-10-12 08:06:32 EDT
Verified on
Version :	
3.3.0.GA Update 04
Build Number :	
821a526:fa7b1a1

Note You need to log in before you can comment on or make changes to this bug.