Bug 1264451 - ovirt executables should be prefixed by ovirt
ovirt executables should be prefixed by ovirt
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
4.0.0
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Lev Veyde
Petr Kubica
: Tracking
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 09:29 EDT by Sandro Bonazzola
Modified: 2016-08-01 08:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-01 08:29:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
sbonazzo: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54459 None None None 2016-03-22 09:48 EDT

  None (edit)
Description Sandro Bonazzola 2015-09-18 09:29:06 EDT
From Alon Bar-Lev: 
Legacy reminder 4.0: 

All programs at /usr/{s,}bin should be prefixed by ovirt-.
Maybe there are some that can be removed.

Additional notes:
engine-log-collector and engine-{iso,image}-uploader are known to need the fix.
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:51:03 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Sandro Bonazzola 2016-03-22 09:49:38 EDT
Lev please check which binaries still miss renaming.
Comment 3 Mike McCune 2016-03-28 18:58:03 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Sandro Bonazzola 2016-05-02 06:04:14 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 5 Petr Kubica 2016-07-27 03:12:42 EDT
Verified in 
ovirt-log-collector-4.0.0-1.el7ev.noarch
ovirt-image-uploader-4.0.0-1.el7ev.noarch
ovirt-iso-uploader-4.0.0-1.el7ev.noarch

# ovirt-
ovirt-image-uploader
ovirt-iso-uploader
ovirt-log-collector
...

# engine-
engine-image-uploader
engine-iso-uploader
...

Note You need to log in before you can comment on or make changes to this bug.