This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1264534 - rhel-osp-director: Unable to launch nova instances with ceph storage, that wasn't installed with the overcloud deployment. The overcloud deployment connected to an existing ceph storage.
rhel-osp-director: Unable to launch nova instances with ceph storage, that wa...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: y2
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 13:46 EDT by Alexander Chuzhoy
Modified: 2016-04-18 02:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-18 14:13:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/nova and /var/log/nova/nova-compute.log (121.86 KB, application/x-gzip)
2015-09-18 13:49 EDT, Alexander Chuzhoy
no flags Details

  None (edit)
Description Alexander Chuzhoy 2015-09-18 13:46:19 EDT
rhel-osp-director: Unable to launch nova instances with ceph storage, that wasn't installed with the overcloud deployment. The overcloud deployment connected to an existing ceph storage.


Environment:
openstack-tripleo-heat-templates-0.8.6-62.el7ost.noarch
instack-undercloud-2.1.2-26.el7ost.noarch

Steps to reproduce:
1. Deploy an overcloud with existing external ceph storage.
Here's the deployment command:
openstack overcloud deploy --templates --control-scale 3 --compute-scale 1 --ceph-storage-scale 0 -e <yaml> -e /usr/share/openstack-tripleo-heat-templates/environments/puppet-ceph-external.yaml  --ntp-server x.x.x.x   --timeout 90 --compute-flavor compute --control-flavor control
2. Connect to the overcloud, create networks, download glance image and attempt to boot the instance.


Result:
The instance gets status: ERROR 

Expected result:
The instance should be boot successfully.



Note: I was able to create the glance and cinder images on the external ceph storage.
Comment 2 Alexander Chuzhoy 2015-09-18 13:49:31 EDT
Created attachment 1075019 [details]
/etc/nova and /var/log/nova/nova-compute.log
Comment 3 Alexander Chuzhoy 2015-09-18 14:13:59 EDT
It was due to a misconfigured network

Note You need to log in before you can comment on or make changes to this bug.