Bug 1264548 - provides python3 vs python34
provides python3 vs python34
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: python34 (Show other bugs)
epel7
ppc64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Petr Viktorin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 15:02 EDT by Mark Hamzy
Modified: 2018-03-01 10:32 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-01 10:32:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Hamzy 2015-09-18 15:02:50 EDT
Can anyone explain what the deal is for python3 between fedora21 and rhel71?

I tried to do the following, which failed:

<mock-chroot>sh-4.2# yum-builddep libepoxy-1.2-4.fc23.src.rpm
Error: No Package found for python3

[root@rhel71-test ~]# uname -a
Linux rhel71-test 3.10.0-229.el7.ppc64 #1 SMP Thu Jan 29 18:40:45 EST 2015 ppc64 ppc64 ppc64 GNU/Linux
[root@rhel71-test ~]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.1 (Maipo)
[root@rhel71-test ~]# yum provides python3
...
No matches found
[root@rhel71-test ~]# repoquery --provides python34.ppc64
python(abi) = 3.4
python34 = 3.4.3-2.el7
python34(ppc-64) = 3.4.3-2.el7
[root@rhel71-test ~]# yum info python34
Available Packages
Name        : python34
Arch        : ppc64
Version     : 3.4.3
Release     : 2.el7
Size        : 49 k
Repo        : rhel-7-epel/ppc64
Summary     : Version 3 of the Python programming language aka Python 3000
URL         : http://www.python.org/
License     : Python
Description : Python 3 is a new version of the language that is incompatible with the 2.x
            : line of releases. The language is mostly the same, but many details, especially
            : how built-in objects like dictionaries and strings work, have changed
            : considerably, and a lot of deprecated features have finally been removed.


[root@hamzy-baby mock]# uname -a
Linux hamzy-baby 3.17.4-301.fc21.ppc64p7 #1 SMP Mon Dec 1 00:50:18 MST 2014 ppc64 ppc64 ppc64 GNU/Linux
[root@hamzy-baby mock]# cat /etc/redhat-release
Fedora release 21 (Twenty One)
[root@hamzy-baby mock]# yum provides python3
...
python3-3.4.1-16.fc21.ppc64 : Version 3 of the Python programming language aka Python 3000
...
[root@hamzy-baby mock]# repoquery --provides python3.ppc64
python(abi) = 3.4
python3 = 3.4.1-16.fc21
python3(ppc-64) = 3.4.1-16.fc21
[root@hamzy-baby mock]# yum info python3
Installed Packages
Name        : python3
Arch        : ppc64p7
Version     : 3.4.1
Release     : 16.fc21
Size        : 92 k
Repo        : installed
From repo   : anaconda
Summary     : Version 3 of the Python programming language aka Python 3000
URL         : http://www.python.org/
License     : Python
Description : Python 3 is a new version of the language that is incompatible with the 2.x
            : line of releases. The language is mostly the same, but many details, especially
            : how built-in objects like dictionaries and strings work, have changed
            : considerably, and a lot of deprecated features have finally been removed.

Available Packages
Name        : python3
Arch        : ppc64
Version     : 3.4.1
Release     : 16.fc21
Size        : 52 k
Repo        : fedora/21/ppc64
Summary     : Version 3 of the Python programming language aka Python 3000
URL         : http://www.python.org/
License     : Python
Description : Python 3 is a new version of the language that is incompatible with the 2.x
            : line of releases. The language is mostly the same, but many details, especially
            : how built-in objects like dictionaries and strings work, have changed
            : considerably, and a lot of deprecated features have finally been removed.
Comment 2 Petr Viktorin 2016-01-28 08:41:45 EST
Fedora uses "python3".
EPEL uses "python34" and "python35", because the cycle is so long that it needs to handle multiple Python3 versions in parallel.
Comment 3 Robert Kuska 2016-03-09 05:49:46 EST
I am changing this to the right component as python3 is not present in rhel-7.

Read more at https://fedorahosted.org/fpc/ticket/567
Comment 4 Felix Schwarz 2017-01-10 05:32:23 EST
I guess the reason for "python34" was explained properly so maybe this can be closed?
Comment 5 Petr Viktorin 2018-03-01 10:32:34 EST
Closing; please re-open if you need more explanation.

Note You need to log in before you can comment on or make changes to this bug.