Bug 1264563 - Packages missing from Oracle i386 repository for RHEL 6.
Packages missing from Oracle i386 repository for RHEL 6.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: releng (Show other bugs)
6.1.2
Unspecified Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Tomas Mlcoch
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 15:58 EDT by Kurt Bechstein
Modified: 2015-10-15 16:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 16:03:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Result from synchronizing Red Hat Enterprise Linux 6 Server - Oracle Java RPMs i386 6Server (100.92 KB, image/png)
2015-10-15 14:44 EDT, Og Maciel
no flags Details
DynFlow raw data for the synchronization process (47.67 KB, text/plain)
2015-10-15 14:46 EDT, Og Maciel
no flags Details

  None (edit)
Description Kurt Bechstein 2015-09-18 15:58:41 EDT
Description of problem:On our Satellite 6 installation everyday when our sync plan executes I see the following get logged on the system.  It appears as those there is a disjoin between the metadata and what is in the repository.

Sep 18 06:00:16 rhsat1 pulp: pulp_rpm.plugins.importers.yum.repomd.alternate:INFO: The content container reported: {'downloads': {'___/primary/___': {'total_failed': 16, 'total_succeeded': 0}}, 'total_sources': 0} for base URL: https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/
Sep 18 06:00:19 rhsat1 pulp: pulp.server.event.http:INFO: (7350-88736) t/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.7.0-oracle-plugin-1.7.0.85-1jpp.2.el6_6.i686.rpm', u'errors': [u'Not Found']}, {u'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.7.0-oracle-jdbc-1.7.0.85-1jpp.2.el6_6.i686.rpm', u'errors': [u'Not Found']}, {u'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.8.0-oracle-1.8.0.51-1jpp.2.el6_6.i686.rpm', u'errors': [u'Not Found']}, {u'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.7.0-oracle-src-1.7.0.85-1jpp.2.el6_6.i686.rpm', u'errors': [u'Not Found']}, {u'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.8.0-oracle-devel-1.8.0.51-1jpp.2.el6_6.i686.rpm', u'errors': [u'Not Found']}, {u'url': u'https://cdn.redhat.com/content/dist/rhel!
 /server/6/6Server/i386/oracle-java/os/Packages/java-1.8.0-oracle-javafx-1.8.0.51-1jpp.2.el6_6.i686.rpm', u'errors': [u'Not Found']}, {u'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.8.0-oracle-jdbc-1.8.0.51-1jpp.2.el6_6.i686.rpm', u'errors': [u'Not Found']}, {u'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.8.0-oracle-plugin-1.8.0.51-1jpp.2.el6_6.i686.rpm', u'errors': [u'Not Found']}, {u'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.8.0-oracle-src-1.8.0.51-1jpp.2.el6_6.i686.rpm', u'errors': [u'Not Found']}]}, u'comps': {u'state': u'FINISHED'}, u'distribution': {u'items_total': 0, u'state': u'FINISHED', u'error_details': [], u'items_left': 0}, u'errata': {u'state': u'FINISHED'}, u'metadata': {u'state': u'FINISHED'}}}, u'state': u'running', u'worker_name': u'reserved_resource_worker-3@rhsat1.bgsu.edu', u'result'!
 : None, u'error': None, u'_id': ObjectId('55fbe0a05a1d46bae1b6!
 b1ae'
Sep 18 06:00:19 rhsat1 pulp: pulp.server.event.http:INFO: (7350-88736) 60160c1cb522c9b1'}, 'event_type': 'repo.sync.finish', 'payload': {'importer_id': u'yum_importer', 'exception': None, 'repo_id': u'BGSU_ITS-Oracle_Java__for_RHEL_Server_-Red_Hat_Enterprise_Linux_6_Server_-_Oracle_Java_RPMs_i386_6Server', 'traceback': None, 'started': '2015-09-18T10:00:00Z', '_ns': u'repo_sync_results', 'completed': '2015-09-18T10:00:19Z', 'importer_type_id': u'yum_importer', 'error_message': None, 'summary': {'content': {'state': 'FINISHED'}, 'comps': {'state': 'FINISHED'}, 'distribution': {'state': 'FINISHED'}, 'errata': {'state': 'FINISHED'}, 'metadata': {'state': 'FINISHED'}}, 'added_count': 0, 'result': 'success', 'updated_count': 17, 'details': {'content': {'size_total': 310647028, 'items_left': 0, 'items_total': 16, 'state': 'FINISHED', 'size_left': 0, 'details': {'rpm_total': 16, 'rpm_done': 16, 'drpm_total': 0, 'drpm_done': 0}, 'error_details': [{'url': u'https://cdn.redhat.com/con!
 tent/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.6.0-sun-demo-1.6.0.101-1jpp.1.el6_6.i686.rpm', 'errors': ['Not Found']}, {'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.6.0-sun-plugin-1.6.0.101-1jpp.1.el6_6.i686.rpm', 'errors': ['Not Found']}, {'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.6.0-sun-src-1.6.0.101-1jpp.1.el6_6.i686.rpm', 'errors': ['Not Found']}, {'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.6.0-sun-jdbc-1.6.0.101-1jpp.1.el6_6.i686.rpm', 'errors': ['Not Found']}, {'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.7.0-oracle-1.7.0.85-1jpp.2.el6_6.i686.rpm', 'errors': ['Not Found']}, {'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.7.0-oracle-devel-1.7.0.85-1jpp.2.el6_!
 6.i686.rpm', 'errors': ['Not Found']}, {'url': u'https://cdn.r!
 edhat
Sep 18 06:00:19 rhsat1 pulp: pulp.server.event.http:INFO: (7350-88736) el/server/6/6Server/i386/oracle-java/os/Packages/java-1.7.0-oracle-javafx-1.7.0.85-1jpp.2.el6_6.i686.rpm', 'errors': ['Not Found']}, {'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.7.0-oracle-plugin-1.7.0.85-1jpp.2.el6_6.i686.rpm', 'errors': ['Not Found']}, {'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.7.0-oracle-jdbc-1.7.0.85-1jpp.2.el6_6.i686.rpm', 'errors': ['Not Found']}, {'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.8.0-oracle-1.8.0.51-1jpp.2.el6_6.i686.rpm', 'errors': ['Not Found']}, {'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.7.0-oracle-src-1.7.0.85-1jpp.2.el6_6.i686.rpm', 'errors': ['Not Found']}, {'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/!
 oracle-java/os/Packages/java-1.8.0-oracle-devel-1.8.0.51-1jpp.2.el6_6.i686.rpm', 'errors': ['Not Found']}, {'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.8.0-oracle-javafx-1.8.0.51-1jpp.2.el6_6.i686.rpm', 'errors': ['Not Found']}, {'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.8.0-oracle-jdbc-1.8.0.51-1jpp.2.el6_6.i686.rpm', 'errors': ['Not Found']}, {'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.8.0-oracle-plugin-1.8.0.51-1jpp.2.el6_6.i686.rpm', 'errors': ['Not Found']}, {'url': u'https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/oracle-java/os/Packages/java-1.8.0-oracle-src-1.8.0.51-1jpp.2.el6_6.i686.rpm', 'errors': ['Not Found']}]}, 'comps': {'state': 'FINISHED'}, 'distribution': {'items_total': 0, 'state': 'FINISHED', 'error_details': [], 'items_left': 0}, 'errata': {'state': 'FINISHED'}, !
 'metadata': {'state': 'FINISHED'}}, 'id': '55fbe0b360160c1cb61!
 7094c


Version-Release number of selected component (if applicable):
Satellite 6.1.2.

How reproducible:
It happens every morning when the repositories sync up.

Steps to Reproduce:
1.Let the sync plan run its course.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Og Maciel 2015-10-15 14:44 EDT
Created attachment 1083337 [details]
Result from synchronizing Red Hat Enterprise Linux 6 Server - Oracle Java RPMs i386 6Server

The attached screenshot shows that when one synchronizes "Red Hat Enterprise Linux 6 Server - Oracle Java RPMs i386 6Server" you end up with 18 packages that are missing ('Not Found'). I firmly believe that this is not a Satellite issue but one for our RCM team to address.
Comment 2 Og Maciel 2015-10-15 14:46 EDT
Created attachment 1083338 [details]
DynFlow raw data for the synchronization process

In the attached file you can see that 18 packages were not found while synchronizing the "Red Hat Enterprise Linux 6 Server - Oracle Java RPMs i386 6Server" repository. Since this is the result from the very first time I attempted to synchronize this repository, I believe that subsequent synchronizations (the issue claims that this occurs every time a sync plan runs) would yield the same result.
Comment 5 Brad Buckingham 2015-10-15 16:03:03 EDT
The CDN has been refreshed and the missing packages appear to now be in place.

Thank you for raising this issue and please let us know if you encounter further issues!

Note You need to log in before you can comment on or make changes to this bug.