Bug 1264568 - Volume Deprecation errors in log
Volume Deprecation errors in log
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.5.0
Unspecified Unspecified
low Severity medium
: GA
: cfme-future
Assigned To: Rich Oliveri
Satyajit Bulage
smartstate:provider:openstack
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 16:29 EDT by Thom Carlin
Modified: 2016-11-15 09:02 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-15 09:02:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2015-09-18 16:29:54 EDT
Description of problem:

During SmartState Analysis, see DEPRECATION errors in log

Version-Release number of selected component (if applicable):

5.5.0.1-alpha1.20150915151429_2230bd4

How reproducible:

100%

Steps to Reproduce:
1. Perform SmartState Analysis on RHOS Instances
2.
3.

Actual results:

Errors in log

Expected results:

No errors

Additional info:

evm.log excerpt:

[fog][DEPRECATION] Calling OpenStack[:volume].list_snapshots(true) is deprecated, use .list_snapshots_detailed instead
Comment 2 Greg Blomquist 2015-09-24 10:09:56 EDT
This will be fixed with an update to Fog.
Comment 3 Greg Blomquist 2015-10-12 14:13:48 EDT
Moving this to Smart State, but technically it should be fixed with https://github.com/ManageIQ/manageiq/pull/4490
Comment 4 Jerry Keselman 2016-11-09 16:01:23 EST
Fog was updated over a year ago and this deprecation message was said to be removed.  Can you re-test to see if this no longer occurs?  Thanks.
Comment 5 Thom Carlin 2016-11-09 18:13:31 EST
Moving needinfo? to proper team
Comment 6 Satyajit Bulage 2016-11-15 05:14:38 EST
Hello Jerry,

I performed SmartState Analysis on Instance and grepped for FOG-deprication error but I could not found any FOG logs in evm.log
Tested version:- 5.7.0.10-beta3.20161109111947_9a61b18

Thanks,
Satyajit Bulage.
Comment 7 Jerry Keselman 2016-11-15 09:02:58 EST
Closing since this was fixed with the upgraded Fog.

Note You need to log in before you can comment on or make changes to this bug.