Bug 1264611 - vsync problem after resuming from suspend
vsync problem after resuming from suspend
Status: CLOSED DUPLICATE of bug 1268143
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-19 05:02 EDT by rudolf
Modified: 2016-03-23 18:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-23 18:00:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rudolf 2015-09-19 05:02:04 EDT
Description of problem:

Gnome shell laggs after resuming from suspend, characters sometimes repeat when typing. Moving windows is laggy.

 
Version-Release number of selected component (if applicable):
Name        : xorg-x11-drv-intel
Arch        : x86_64
Version     : 2.99.917
Release     : 8.20150615.el7


How reproducible:
always

Steps to Reproduce:
1. suspend computer
2. wake computer from sleep
3. run glxgears


Actual results:

glxgears shows that framerate is not synchronized to monitor refresh rate

Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
387 frames in 5.0 seconds = 76.930 FPS
250 frames in 5.1 seconds = 49.335 FPS
263 frames in 5.0 seconds = 52.591 FPS
172 frames in 5.6 seconds = 30.524 FPS
466 frames in 5.0 seconds = 93.172 FPS
349 frames in 5.0 seconds = 69.793 FPS
226 frames in 5.4 seconds = 42.100 FPS
183 frames in 5.0 seconds = 36.596 FPS


Expected results:

this is normal glxgears framerate after rebooting computer

Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
586 frames in 5.0 seconds = 116.867 FPS
299 frames in 5.0 seconds = 59.795 FPS
299 frames in 5.0 seconds = 59.795 FPS
299 frames in 5.0 seconds = 59.794 FPS
299 frames in 5.0 seconds = 59.794 FPS
299 frames in 5.0 seconds = 59.794 FPS
299 frames in 5.0 seconds = 59.794 FPS
299 frames in 5.0 seconds = 59.794 FPS


Additional info:
Intel G41
Comment 2 rudolf 2015-10-01 18:38:41 EDT
Please close this bug, its not caused by Intel driver but probably by kernel/CPU power management issue: bz 1268143
Comment 3 Lyude 2016-03-23 18:00:32 EDT

*** This bug has been marked as a duplicate of bug 1268143 ***

Note You need to log in before you can comment on or make changes to this bug.