Bug 1264670 - Failed to add resource root 'slf4j-jdk14.jar' at path 'slf4j-jdk14.jar'
Failed to add resource root 'slf4j-jdk14.jar' at path 'slf4j-jdk14.jar'
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Setup.Engine (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Martin Perina
Karolína Hajná
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-20 09:08 EDT by Yedidyah Bar David
Modified: 2016-05-19 21:24 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:18:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: planning_ack+
oourfali: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48018 master MERGED packaging: Require slf4j-jdk14 on Fedora Never
oVirt gerrit 48123 ovirt-engine-3.6 MERGED packaging: Require slf4j-jdk14 on Fedora Never

  None (edit)
Description Yedidyah Bar David 2015-09-20 09:08:59 EDT
Description of problem:

Running engine-setup on fedora 22 fails with:

[ ERROR ] Failed to execute stage 'Misc configuration': Command '/usr/bin/ovirt-aaa-jdbc-tool' failed to execute

setup log has:

2015-09-20 15:34:04 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine.config.aaajdbc plugin.execute:941 execute-output: ('/usr/bin/ovirt-aaa-jdbc-tool', '--db-config=/etc/ovirt-engine/aaa/internal.properties', 'query', '--what=user', '--pattern=name=admin') stderr:
Exception in thread "main" org.jboss.modules.ModuleLoadError: Error loading module from /usr/share/ovirt-engine/modules/tools/org/slf4j/main/module.xml
        at org.jboss.modules.ModuleLoadException.toError(ModuleLoadException.java:78)
        at org.jboss.modules.Module.getPathsUnchecked(Module.java:1392)
        at org.jboss.modules.Module.loadModuleClass(Module.java:563)
        at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:205)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:459)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:408)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:389)
        at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:134)
        at org.ovirt.engine.extension.aaa.jdbc.binding.cli.Cli.<clinit>(Cli.java:213)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:348)
        at org.jboss.modules.Module.run(Module.java:302)
        at org.jboss.modules.Main.main(Main.java:460)
Caused by: org.jboss.modules.xml.XmlPullParserException: Failed to add resource root 'slf4j-jdk14.jar' at path 'slf4j-jdk14.jar' (position: END_TAG seen ...path="slf4j-api.jar"/>\n    <resource-root path="slf4j-jdk14.jar"/>... @11:44) caused by: java.io.FileNotFoundException: /usr/share/ovirt-engine/modules/tools/org/slf4j/main/slf4j-jdk14.jar (No such file or directory)
        at org.jboss.modules.ModuleXmlParser.parseResourceRoot(ModuleXmlParser.java:723)
        at org.jboss.modules.ModuleXmlParser.parseResources(ModuleXmlParser.java:572)
        at org.jboss.modules.ModuleXmlParser.parseModuleContents(ModuleXmlParser.java:394)
        at org.jboss.modules.ModuleXmlParser.parseDocument(ModuleXmlParser.java:219)
        at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:153)
        at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:132)
        at org.jboss.modules.LocalModuleFinder$1.run(LocalModuleFinder.java:154)
        at org.jboss.modules.LocalModuleFinder$1.run(LocalModuleFinder.java:148)
        at java.security.AccessController.doPrivileged(Native Method)
        at org.jboss.modules.LocalModuleFinder.findModule(LocalModuleFinder.java:148)
        at org.jboss.modules.ModuleLoader.findModule(ModuleLoader.java:455)
        at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:358)
        at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:305)
        at org.jboss.modules.Module.addPaths(Module.java:1036)
        at org.jboss.modules.Module.link(Module.java:1406)
        at org.jboss.modules.Module.getPaths(Module.java:1367)
        at org.jboss.modules.Module.getPathsUnchecked(Module.java:1390)
        ... 11 more


Version-Release number of selected component (if applicable):

Current master

How reproducible:

Not sure, probably always

Steps to Reproduce:
1. engine-setup, or directly run: ovirt-aaa-jdbc-tool --db-config=/etc/ovirt-engine/aaa/internal.properties query --what=user --pattern=name=admin
2.
3.

Actual results:

Fails

Expected results:

Succeeds

Additional info:
Comment 1 Yedidyah Bar David 2015-09-20 09:13:53 EDT
# ls -l /usr/share/ovirt-engine/modules/tools/org/slf4j/main/slf4j-jdk14.jar
lrwxrwxrwx. 1 root root 37 Sep 18 23:07 /usr/share/ovirt-engine/modules/tools/org/slf4j/main/slf4j-jdk14.jar -> /usr/share/java/slf4j/slf4j-jdk14.jar

ls -l /usr/share/java/slf4j/slf4j*
-rw-r--r--. 1 root root 32141 Jan 19  2015 /usr/share/java/slf4j/slf4j-api.jar
-rw-r--r--. 1 root root  8932 Jan 19  2015 /usr/share/java/slf4j/slf4j-log4j12.jar
-rw-r--r--. 1 root root  4120 Jan 19  2015 /usr/share/java/slf4j/slf4j-nop.jar
-rw-r--r--. 1 root root 10714 Jan 19  2015 /usr/share/java/slf4j/slf4j-simple.jar

# rpm -qa | grep slf
slf4j-log4j12-1.7.10-1.fc22.noarch
slf4j-1.7.10-1.fc22.noarch
Comment 2 Martin Perina 2015-10-14 03:51:03 EDT
I was unable to reproduce it, it worked fine today on my F22 with oVirt 3.6.0 RC1. The only strange thing is, that you don't have installed package slf4j-jdk14, which is installed when you install ovirt-engine.

Any special (non default) option selected during engine-setup?
Comment 3 Yogesh Sharma 2015-10-27 23:44:12 EDT
run following command 
dnf install slf4j-jdk14-1.7.10-1.fc22.noarch

Afetr this run engine-setup again
Comment 4 Yaniv Lavi 2015-10-29 08:35:25 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 5 Karolína Hajná 2015-12-03 06:51:15 EST
verified on ovirt-engine-setup-3.6.1-1.fc22.noarch
Comment 6 Sandro Bonazzola 2015-12-16 07:18:54 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.